summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2013-06-17 08:47:58 +0000
committerDirkjan Ochtman <djc@gentoo.org>2013-06-17 08:47:58 +0000
commit3e8c26eb55794bfc25ac19231b0b4a0dc70502dd (patch)
tree220387629fe1193efee8d2854d2bdf62cad7abb7 /dev-python/redis-py
parentDrop old. (diff)
downloadgentoo-2-3e8c26eb55794bfc25ac19231b0b4a0dc70502dd.tar.gz
gentoo-2-3e8c26eb55794bfc25ac19231b0b4a0dc70502dd.tar.bz2
gentoo-2-3e8c26eb55794bfc25ac19231b0b4a0dc70502dd.zip
Version bump redis-py to 2.7.6.
(Portage version: 2.1.12.5/cvs/Linux x86_64, signed Manifest commit with key 6B065BFB)
Diffstat (limited to 'dev-python/redis-py')
-rw-r--r--dev-python/redis-py/ChangeLog7
-rw-r--r--dev-python/redis-py/redis-py-2.7.6.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/dev-python/redis-py/ChangeLog b/dev-python/redis-py/ChangeLog
index e099da6e2997..54a395eea982 100644
--- a/dev-python/redis-py/ChangeLog
+++ b/dev-python/redis-py/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/redis-py
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/redis-py/ChangeLog,v 1.38 2013/05/22 07:48:38 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/redis-py/ChangeLog,v 1.39 2013/06/17 08:47:58 djc Exp $
+
+*redis-py-2.7.6 (17 Jun 2013)
+
+ 17 Jun 2013; Dirkjan Ochtman <djc@gentoo.org> +redis-py-2.7.6.ebuild:
+ Version bump redis-py to 2.7.6.
*redis-py-2.7.5 (22 May 2013)
diff --git a/dev-python/redis-py/redis-py-2.7.6.ebuild b/dev-python/redis-py/redis-py-2.7.6.ebuild
new file mode 100644
index 000000000000..c9c761d3fd49
--- /dev/null
+++ b/dev-python/redis-py/redis-py-2.7.6.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/redis-py/redis-py-2.7.6.ebuild,v 1.1 2013/06/17 08:47:58 djc Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+MY_PN="redis"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python client for Redis key-value store"
+HOMEPAGE="http://github.com/andymccurdy/redis-py http://pypi.python.org/pypi/redis"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-db/redis )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # Disable pubsub and encoding tests, they do not seem to support
+ # UNIX socket connectivity.
+ sed -i -e '/PubSub/d' -e '/Encoding/d' \
+ -e '/use_hiredis:/d' tests/__init__.py || die
+
+ # Make sure that tests will be used from BUILD_DIR rather than cwd.
+ mv tests tests-hidden || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+ if use test; then
+ cp -r tests-hidden "${BUILD_DIR}"/tests || die
+ fi
+}
+
+src_test() {
+# local DISTUTILS_NO_PARALLEL_BUILD=1
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ local pidfile=${T}/redis-${EPYTHON}.pid
+ local sock=${T}/redis-${EPYTHON}.sock
+
+ sed -i -e "s:port=6379:unix_socket_path=\"${sock}\":" \
+ "${BUILD_DIR}"/tests/*.py || die
+
+ # XXX: find a way to make sure it is killed
+
+ "${EPREFIX}"/usr/sbin/redis-server \
+ --pidfile "${pidfile}" \
+ --port 0 \
+ --unixsocket "${sock}" \
+ --daemonize yes || die
+ PYTHONPATH="${PYTHONPATH}:${BUILD_DIR}" \
+ esetup.py test
+ kill "$(<"${pidfile}")"
+}