summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-04-02 16:22:20 +0000
committerJustin Lecher <jlec@gentoo.org>2012-04-02 16:22:20 +0000
commit7c3a903049f0b8d35095cb1c5ab27c4431d665b8 (patch)
tree32f48c618f3ec48423518da28ae37eb9f81fbf98 /dev-python/rdflib
parentDrop default enabled use flag prison as it is not a critical feature. (diff)
downloadgentoo-2-7c3a903049f0b8d35095cb1c5ab27c4431d665b8.tar.gz
gentoo-2-7c3a903049f0b8d35095cb1c5ab27c4431d665b8.tar.bz2
gentoo-2-7c3a903049f0b8d35095cb1c5ab27c4431d665b8.zip
backport latest fix for tests, #410555
(Portage version: 2.2.0_alpha98/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/rdflib')
-rw-r--r--dev-python/rdflib/ChangeLog8
-rw-r--r--dev-python/rdflib/files/rdflib-3.1.0-test.patch20
-rw-r--r--dev-python/rdflib/rdflib-3.1.0.ebuild13
3 files changed, 35 insertions, 6 deletions
diff --git a/dev-python/rdflib/ChangeLog b/dev-python/rdflib/ChangeLog
index 545a8a49790a..935575f49115 100644
--- a/dev-python/rdflib/ChangeLog
+++ b/dev-python/rdflib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/rdflib
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rdflib/ChangeLog,v 1.11 2011/09/12 21:20:56 neurogeek Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rdflib/ChangeLog,v 1.12 2012/04/02 16:22:20 jlec Exp $
+
+ 02 Apr 2012; Justin Lecher <jlec@gentoo.org> rdflib-3.1.0.ebuild,
+ +files/rdflib-3.1.0-test.patch:
+ backport latest fix for tests, #410555
12 Sep 2011; Jesus Rivero <neurogeek@gentoo.org> rdflib-3.1.0.ebuild:
Delete "zodb" USE flag. Patch by Arfrever.
diff --git a/dev-python/rdflib/files/rdflib-3.1.0-test.patch b/dev-python/rdflib/files/rdflib-3.1.0-test.patch
new file mode 100644
index 000000000000..aea1bf5ac723
--- /dev/null
+++ b/dev-python/rdflib/files/rdflib-3.1.0-test.patch
@@ -0,0 +1,20 @@
+ rdflib/__init__.py | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/rdflib/__init__.py b/rdflib/__init__.py
+index b781031..44efb0b 100644
+--- a/rdflib/__init__.py
++++ b/rdflib/__init__.py
+@@ -15,10 +15,10 @@ A tiny example:
+ >>> import rdflib
+
+ >>> g = rdflib.Graph()
+- >>> result = g.parse("http://eikeon.com/foaf.rdf")
++ >>> result = g.parse("http://www.w3.org/2000/10/swap/test/meet/white.rdf")
+
+ >>> print "graph has %s statements." % len(g)
+- graph has 34 statements.
++ graph has 19 statements.
+ >>>
+ >>> for s, p, o in g:
+ ... if (s, p, o) not in g:
diff --git a/dev-python/rdflib/rdflib-3.1.0.ebuild b/dev-python/rdflib/rdflib-3.1.0.ebuild
index 6d03389dafb2..25e78283b7f1 100644
--- a/dev-python/rdflib/rdflib-3.1.0.ebuild
+++ b/dev-python/rdflib/rdflib-3.1.0.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rdflib/rdflib-3.1.0.ebuild,v 1.2 2011/09/12 21:20:56 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rdflib/rdflib-3.1.0.ebuild,v 1.3 2012/04/02 16:22:20 jlec Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
+RESTRICT_PYTHON_ABIS="3.* *-pypy-*"
-inherit distutils
+inherit distutils eutils
DESCRIPTION="RDF library containing a triple store and parser/serializer"
HOMEPAGE="http://www.rdflib.net/ http://pypi.python.org/pypi/rdflib"
@@ -25,6 +25,11 @@ RDEPEND="berkdb? ( dev-python/bsddb3 )
DEPEND="${RDEPEND}
test? ( dev-python/nose )"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-test.patch
+ distutils_src_prepare
+}
+
src_test() {
testing() {
PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib)" "$(PYTHON)" run_tests.py