summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-10-27 07:24:52 +0000
committerIan Delaney <idella4@gentoo.org>2014-10-27 07:24:52 +0000
commit1fd36099b76a184e5b46b79e759e6e0c99cd6dad (patch)
tree8e0304a962216e103f83268f0545e0e38c596419 /dev-python/qrcode
parentVersion bump. (diff)
downloadgentoo-2-1fd36099b76a184e5b46b79e759e6e0c99cd6dad.tar.gz
gentoo-2-1fd36099b76a184e5b46b79e759e6e0c99cd6dad.tar.bz2
gentoo-2-1fd36099b76a184e5b46b79e759e6e0c99cd6dad.zip
bump; updrade deps & install phase, retrict test phase for now due to failures
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/qrcode')
-rw-r--r--dev-python/qrcode/ChangeLog7
-rw-r--r--dev-python/qrcode/qrcode-5.1.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/qrcode/ChangeLog b/dev-python/qrcode/ChangeLog
index fa13daf1094c..45916855bd92 100644
--- a/dev-python/qrcode/ChangeLog
+++ b/dev-python/qrcode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/qrcode
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qrcode/ChangeLog,v 1.5 2014/06/21 22:55:56 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qrcode/ChangeLog,v 1.6 2014/10/27 07:24:52 idella4 Exp $
+
+*qrcode-5.1 (27 Oct 2014)
+
+ 27 Oct 2014; Ian Delaney <idella4@gentoo.org> +qrcode-5.1.ebuild:
+ bump; updrade deps & install phase, retrict test phase for now due to failures
*qrcode-5.0.1 (21 Jun 2014)
diff --git a/dev-python/qrcode/qrcode-5.1.ebuild b/dev-python/qrcode/qrcode-5.1.ebuild
new file mode 100644
index 000000000000..0102da64f8c1
--- /dev/null
+++ b/dev-python/qrcode/qrcode-5.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qrcode/qrcode-5.1.ebuild,v 1.1 2014/10/27 07:24:52 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="QR Code generator on top of PIL"
+HOMEPAGE="https://pypi.python.org/pypi/qrcode"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# Tests pass run from source, but a few fail run from the ebuild. For now,
+# RESTRICT=test
+
+# optional deps:
+# - pillow and lxml for svg backend, set as hard deps
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python{2_7) )"
+
+python_test() {
+ "${PYTHON}" -m unittest dicover || die "Testing failed with ${EPYTHON}"
+}
+
+src_install() {
+ distutils-r1_src_install
+ doman doc/qr.1
+}