summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-04-02 08:09:35 +0000
committerIan Delaney <idella4@gentoo.org>2014-04-02 08:09:35 +0000
commit475f5f1de065c9110ff554879bcf5082dad80d2a (patch)
tree7b44c8dd5a4334c9b845fd2b8dcd8e844fad3961 /dev-python/pyzmq
parentVersion bump to 0.3.7. Corrected USE flag description of dvdnav. Proxied comm... (diff)
downloadgentoo-2-475f5f1de065c9110ff554879bcf5082dad80d2a.tar.gz
gentoo-2-475f5f1de065c9110ff554879bcf5082dad80d2a.tar.bz2
gentoo-2-475f5f1de065c9110ff554879bcf5082dad80d2a.zip
correction to deps, tidy to test phase, update to python_install_all phase
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pyzmq')
-rw-r--r--dev-python/pyzmq/ChangeLog5
-rw-r--r--dev-python/pyzmq/pyzmq-14.0.1.ebuild17
2 files changed, 11 insertions, 11 deletions
diff --git a/dev-python/pyzmq/ChangeLog b/dev-python/pyzmq/ChangeLog
index 73dcaf0addec..f3aa6dcee8cc 100644
--- a/dev-python/pyzmq/ChangeLog
+++ b/dev-python/pyzmq/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/pyzmq
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/ChangeLog,v 1.43 2014/03/18 23:03:55 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/ChangeLog,v 1.44 2014/04/02 08:09:35 idella4 Exp $
+
+ 02 Apr 2014; Ian Delaney <idella4@gentoo.org> pyzmq-14.0.1.ebuild:
+ correction to deps, tidy to test phase, update to python_install_all phase
*pyzmq-14.1.1 (18 Mar 2014)
diff --git a/dev-python/pyzmq/pyzmq-14.0.1.ebuild b/dev-python/pyzmq/pyzmq-14.0.1.ebuild
index 39d8cadff0b5..81de37578d85 100644
--- a/dev-python/pyzmq/pyzmq-14.0.1.ebuild
+++ b/dev-python/pyzmq/pyzmq-14.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-14.0.1.ebuild,v 1.3 2014/03/16 02:36:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-14.0.1.ebuild,v 1.4 2014/04/02 08:09:35 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
@@ -23,9 +23,9 @@ RDEPEND=">=net-libs/zeromq-2.1.9
DEPEND="${RDEPEND}
test? (
dev-python/cffi[${PYTHON_USEDEP}]
- dev-python/nose[${PY2_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
dev-python/gevent[${PY2_USEDEP}]
- dev-python/cython[${PY2_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
)"
python_configure_all() {
@@ -38,17 +38,14 @@ python_compile() {
}
python_test() {
- if [[ "${EPYTHON}" == python3* ]]; then
- einfo "Skipping python3 due to many incompatibilities"
+ if python_is_python3; then
+ einfo "Skipping python3 due to lack of support by gevent"
else
- nosetests -svw "${BUILD_DIR}/lib/" || die "Tests fail with ${EPYTHON}"
+ nosetests -svw "${BUILD_DIR}/lib/" || die
fi
}
python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
}