summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2008-12-27 18:31:28 +0000
committerJesus Rivero <neurogeek@gentoo.org>2008-12-27 18:31:28 +0000
commitc0c330752d049025d4b45b0213b50ac3633ccdf1 (patch)
tree90d18d857d0f9357ed998d02e1a3186c1c22554f /dev-python/pyxml/pyxml-0.8.4-r1.ebuild
parentAdd patch to allow hamlib to use the system libltdl instead of a bundled one,... (diff)
downloadgentoo-2-c0c330752d049025d4b45b0213b50ac3633ccdf1.tar.gz
gentoo-2-c0c330752d049025d4b45b0213b50ac3633ccdf1.tar.bz2
gentoo-2-c0c330752d049025d4b45b0213b50ac3633ccdf1.zip
Added python_mod_optimize to postinstall phase
(Portage version: 2.2_rc16/cvs/Linux 2.6.18-gentoo-r3 i686)
Diffstat (limited to 'dev-python/pyxml/pyxml-0.8.4-r1.ebuild')
-rw-r--r--dev-python/pyxml/pyxml-0.8.4-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/pyxml/pyxml-0.8.4-r1.ebuild b/dev-python/pyxml/pyxml-0.8.4-r1.ebuild
index 1eecfbf052ab..91c8726fe7ea 100644
--- a/dev-python/pyxml/pyxml-0.8.4-r1.ebuild
+++ b/dev-python/pyxml/pyxml-0.8.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxml/pyxml-0.8.4-r1.ebuild,v 1.10 2008/11/10 11:31:19 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxml/pyxml-0.8.4-r1.ebuild,v 1.11 2008/12/27 18:31:28 neurogeek Exp $
inherit python distutils
@@ -44,6 +44,10 @@ src_install() {
use examples && cp -r demo "${D}"/usr/share/doc/${PF}
}
+pkg_postinst(){
+ python_mod_optimize "$(python_get_sitedir)/_xmlplus"
+}
+
src_test() {
cd test
PYTHONPATH="$(ls -d ../build/lib.*)" "${python}" regrtest.py \