summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2007-05-31 16:32:20 +0000
committerRob Cakebread <pythonhead@gentoo.org>2007-05-31 16:32:20 +0000
commite190b568908721c256bb9c6da5e2db7baf65c042 (patch)
tree457ae43e0979a3f3b7a21e569447fd57746e7944 /dev-python/python-urljr/python-urljr-1.0.1.ebuild
parentAdd ~x86-fbsd keyword. (diff)
downloadgentoo-2-e190b568908721c256bb9c6da5e2db7baf65c042.tar.gz
gentoo-2-e190b568908721c256bb9c6da5e2db7baf65c042.tar.bz2
gentoo-2-e190b568908721c256bb9c6da5e2db7baf65c042.zip
Initial commit.
(Portage version: 2.1.2.8)
Diffstat (limited to 'dev-python/python-urljr/python-urljr-1.0.1.ebuild')
-rw-r--r--dev-python/python-urljr/python-urljr-1.0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/python-urljr/python-urljr-1.0.1.ebuild b/dev-python/python-urljr/python-urljr-1.0.1.ebuild
new file mode 100644
index 000000000000..3de68d116cf4
--- /dev/null
+++ b/dev-python/python-urljr/python-urljr-1.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-urljr/python-urljr-1.0.1.ebuild,v 1.1 2007/05/31 16:32:20 pythonhead Exp $
+
+
+NEED_PYTHON=2.3
+PYTHON_MODNAME="urljr"
+
+inherit distutils eutils
+
+
+DESCRIPTION="JanRain's URL Utilities"
+HOMEPAGE="http://www.openidenabled.com/openid/libraries/python/"
+SRC_URI="http://www.openidenabled.com/resources/downloads/python-openid/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86"
+SLOT="0"
+IUSE="curl test"
+RDEPEND="curl? ( >=dev-python/pycurl-7.15.1 )
+ test? ( >=dev-python/pycurl-7.15.1 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ #Test fails if it finds 'localhost' instead of '127.0.0.1'
+ epatch ${FILESDIR}/${P}-gentoo-test_fetchers.patch
+}
+
+src_test() {
+ PYTHONPATH=. "${python}" admin/runtests || die "tests failed"
+}
+