summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-10-23 06:17:30 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-10-23 06:17:30 +0000
commitb2efd5eaea566219b52b46f9468bcc96b2babfd7 (patch)
treedda91415124578c3e02e8ba920a1708d1f7546f0 /dev-python/python-troveclient
parentadding for horizon havana support (diff)
downloadgentoo-2-b2efd5eaea566219b52b46f9468bcc96b2babfd7.tar.gz
gentoo-2-b2efd5eaea566219b52b46f9468bcc96b2babfd7.tar.bz2
gentoo-2-b2efd5eaea566219b52b46f9468bcc96b2babfd7.zip
initial commit for python-troveclient for havana horizon support (correct version this time)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/python-troveclient')
-rw-r--r--dev-python/python-troveclient/ChangeLog9
-rw-r--r--dev-python/python-troveclient/python-troveclient-0.1.4.ebuild39
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/python-troveclient/ChangeLog b/dev-python/python-troveclient/ChangeLog
index 60a44d2c90f0..e8b3cc539ec5 100644
--- a/dev-python/python-troveclient/ChangeLog
+++ b/dev-python/python-troveclient/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/python-troveclient
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-troveclient/ChangeLog,v 1.1 2013/10/23 06:10:03 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-troveclient/ChangeLog,v 1.2 2013/10/23 06:17:30 prometheanfire Exp $
+
+*python-troveclient-0.1.4 (23 Oct 2013)
+
+ 23 Oct 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +python-troveclient-0.1.4.ebuild:
+ initial commit for python-troveclient for havana horizon support (correct
+ version this time)
*python-troveclient-1.0.1 (23 Oct 2013)
diff --git a/dev-python/python-troveclient/python-troveclient-0.1.4.ebuild b/dev-python/python-troveclient/python-troveclient-0.1.4.ebuild
new file mode 100644
index 000000000000..4d0f657b5c41
--- /dev/null
+++ b/dev-python/python-troveclient/python-troveclient-0.1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-troveclient/python-troveclient-0.1.4.ebuild,v 1.1 2013/10/23 06:17:30 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="This is a client for the OpenStack Trove API, a scalable relational database service."
+HOMEPAGE="https://github.com/openstack/python-troveclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.5.16[${PYTHON_USEDEP}]
+ <dev-python/pbr-0.6[${PYTHON_USEDEP}]
+ test? ( ~dev-python/pep8-1.4.5[${PYTHON_USEDEP}]
+ ~dev-python/pyflakes-0.7.2[${PYTHON_USEDEP}]
+ ~dev-python/flake8-2.0[${PYTHON_USEDEP}]
+ >=dev-python/hacking-0.5.6[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.7[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.17[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.32[${PYTHON_USEDEP}]
+ >=dev-python/mock-0.8.0[${PYTHON_USEDEP}] )"
+RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ >=dev-python/lxml-2.3[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.6[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${PYTHON} -m subunit.run discover -t ./ ./troveclient/tests || die
+}