summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2006-02-09 00:20:48 +0000
committerChris PeBenito <pebenito@gentoo.org>2006-02-09 00:20:48 +0000
commitbb15c400134a6c96a36ab6ef319bb0ab60c316fd (patch)
tree7dd34ee2dd6db55c0c0884d76359c87ac5417ac0 /dev-python/python-selinux
parentfixed broken encoding in ChangeLog (diff)
downloadgentoo-2-bb15c400134a6c96a36ab6ef319bb0ab60c316fd.tar.gz
gentoo-2-bb15c400134a6c96a36ab6ef319bb0ab60c316fd.tar.bz2
gentoo-2-bb15c400134a6c96a36ab6ef319bb0ab60c316fd.zip
Move source to distfiles, and move python_version out of global scope.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'dev-python/python-selinux')
-rw-r--r--dev-python/python-selinux/ChangeLog6
-rw-r--r--dev-python/python-selinux/files/digest-python-selinux-2.163
-rw-r--r--dev-python/python-selinux/files/python-selinux-2.16.c.bz2bin8500 -> 0 bytes
-rw-r--r--dev-python/python-selinux/python-selinux-2.16.ebuild8
4 files changed, 13 insertions, 4 deletions
diff --git a/dev-python/python-selinux/ChangeLog b/dev-python/python-selinux/ChangeLog
index c525b8661d35..0cfe5505aede 100644
--- a/dev-python/python-selinux/ChangeLog
+++ b/dev-python/python-selinux/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/python-selinux
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.28 2006/02/05 04:33:53 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.29 2006/02/09 00:20:48 pebenito Exp $
+
+ 09 Feb 2006; Chris PeBenito <pebenito@gentoo.org>
+ -files/python-selinux-2.16.c.bz2, python-selinux-2.16.ebuild:
+ Move source to distfiles, and move python_version out of global scope.
05 Feb 2006; Chris PeBenito <pebenito@gentoo.org>
-files/python-selinux-2.15.c.bz2, -python-selinux-2.15.ebuild:
diff --git a/dev-python/python-selinux/files/digest-python-selinux-2.16 b/dev-python/python-selinux/files/digest-python-selinux-2.16
index e69de29bb2d1..28546a89b7e8 100644
--- a/dev-python/python-selinux/files/digest-python-selinux-2.16
+++ b/dev-python/python-selinux/files/digest-python-selinux-2.16
@@ -0,0 +1,3 @@
+MD5 d5dc9417a58fe239af4d9e126be2ceff python-selinux-2.16.c.bz2 8500
+RMD160 f98aac72c759c37a167ca8589c5544438c9ebcd5 python-selinux-2.16.c.bz2 8500
+SHA256 3bcf586902b74c124a8c953ba51bb193ba7732629760f465c41559011bbff1e1 python-selinux-2.16.c.bz2 8500
diff --git a/dev-python/python-selinux/files/python-selinux-2.16.c.bz2 b/dev-python/python-selinux/files/python-selinux-2.16.c.bz2
deleted file mode 100644
index 65467ca0c868..000000000000
--- a/dev-python/python-selinux/files/python-selinux-2.16.c.bz2
+++ /dev/null
Binary files differ
diff --git a/dev-python/python-selinux/python-selinux-2.16.ebuild b/dev-python/python-selinux/python-selinux-2.16.ebuild
index de85fa3ca7c9..23f156766f97 100644
--- a/dev-python/python-selinux/python-selinux-2.16.ebuild
+++ b/dev-python/python-selinux/python-selinux-2.16.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-2.16.ebuild,v 1.3 2006/01/14 01:00:11 spb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-2.16.ebuild,v 1.4 2006/02/09 00:20:48 pebenito Exp $
inherit python
-python_version
DESCRIPTION="Python bindings for SELinux functions"
HOMEPAGE="http://www.gentoo.org/proj/en/hardened/selinux/"
LICENSE="GPL-2"
SLOT="0"
+SRC_URI="${P}.c.bz2"
KEYWORDS="~alpha amd64 mips ppc sparc x86"
#KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~mips"
@@ -21,16 +21,18 @@ S=${WORKDIR}/${PN}
src_unpack() {
mkdir -p ${S}
- bzcat ${FILESDIR}/${P}.c.bz2 > ${S}/selinux.c || die
+ bzcat ${DISTDIR}/${A} > ${S}/selinux.c || die
}
src_compile() {
cd ${S}
+ python_version
einfo "Compiling selinux.so for python ${PYVER}"
gcc -fPIC -shared -o selinux.so -I /usr/include/python${PYVER}/ selinux.c -lselinux || die
}
src_install() {
+ python_version
insinto /usr/lib/python${PYVER}/site-packages
doins selinux.so
}