summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-03-27 21:51:44 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-03-27 21:51:44 +0000
commitbcf186ad8d7f5fe38e3c71da24861d6f6172f6fe (patch)
treed65d75c6e8941efd3bc4dde864585d7a8124974e /dev-python/python-keystoneclient
parentVersion bump. (diff)
downloadgentoo-2-bcf186ad8d7f5fe38e3c71da24861d6f6172f6fe.tar.gz
gentoo-2-bcf186ad8d7f5fe38e3c71da24861d6f6172f6fe.tar.bz2
gentoo-2-bcf186ad8d7f5fe38e3c71da24861d6f6172f6fe.zip
initial fix for CVE-2014-0105 bug 505976 (still need to remove old versions)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/python-keystoneclient')
-rw-r--r--dev-python/python-keystoneclient/ChangeLog8
-rw-r--r--dev-python/python-keystoneclient/python-keystoneclient-0.7.1.ebuild69
2 files changed, 76 insertions, 1 deletions
diff --git a/dev-python/python-keystoneclient/ChangeLog b/dev-python/python-keystoneclient/ChangeLog
index 389041511d6d..25fcb8456701 100644
--- a/dev-python/python-keystoneclient/ChangeLog
+++ b/dev-python/python-keystoneclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-keystoneclient
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-keystoneclient/ChangeLog,v 1.27 2014/03/19 23:06:01 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-keystoneclient/ChangeLog,v 1.28 2014/03/27 21:51:44 prometheanfire Exp $
+
+*python-keystoneclient-0.7.1 (27 Mar 2014)
+
+ 27 Mar 2014; Matthew Thode <prometheanfire@gentoo.org>
+ +python-keystoneclient-0.7.1.ebuild:
+ initial fix for CVE-2014-0105 bug 505976 (still need to remove old versions)
19 Mar 2014; Sébastien Fabbro <bicatali@gentoo.org>
python-keystoneclient-0.6.0.ebuild:
diff --git a/dev-python/python-keystoneclient/python-keystoneclient-0.7.1.ebuild b/dev-python/python-keystoneclient/python-keystoneclient-0.7.1.ebuild
new file mode 100644
index 000000000000..6a75e5bb6089
--- /dev/null
+++ b/dev-python/python-keystoneclient/python-keystoneclient-0.7.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-keystoneclient/python-keystoneclient-0.7.1.ebuild,v 1.1 2014/03/27 21:51:44 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Keystone API"
+HOMEPAGE="https://github.com/openstack/python-keystoneclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.6[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ test? ( >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/hacking-0.8[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.9[${PYTHON_USEDEP}]
+ >=dev-python/httpretty-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/keyring-1.6.1[${PYTHON_USEDEP}]
+ <dev-python/keyring-2.1[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/mox3-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.2[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testresources-0.2.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.2.3[${PYTHON_USEDEP}]
+ ) "
+
+RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.8[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.6[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5.2[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}"/sphinx_mapping.patch
+)
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ # https://bugs.launchpad.net/python-keystoneclient/+bug/1243528
+ testr init
+ testr run || die "testsuite failed under python2.7"
+ flake8 ${PN/python-/}/tests || die "run over tests folder by flake8 drew error"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ use examples && local EXAMPLES=( examples/.)
+ distutils-r1_python_install_all
+}