summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-09-13 19:40:27 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-09-13 19:40:27 +0000
commit40f40ff0974abd85dab37c167b98e78cbc543dc1 (patch)
tree468c9bab0fde1b15e074eb924ce21b7b0883dae7 /dev-python/python-keystoneclient
parentdistutils-r1 compliance (diff)
downloadgentoo-2-40f40ff0974abd85dab37c167b98e78cbc543dc1.tar.gz
gentoo-2-40f40ff0974abd85dab37c167b98e78cbc543dc1.tar.bz2
gentoo-2-40f40ff0974abd85dab37c167b98e78cbc543dc1.zip
updating deps and stuff for distutils-r1
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/python-keystoneclient')
-rw-r--r--dev-python/python-keystoneclient/ChangeLog6
-rw-r--r--dev-python/python-keystoneclient/python-keystoneclient-9999.ebuild29
2 files changed, 25 insertions, 10 deletions
diff --git a/dev-python/python-keystoneclient/ChangeLog b/dev-python/python-keystoneclient/ChangeLog
index a8c7f32e0242..39911c61b82b 100644
--- a/dev-python/python-keystoneclient/ChangeLog
+++ b/dev-python/python-keystoneclient/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/python-keystoneclient
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-keystoneclient/ChangeLog,v 1.14 2013/08/20 18:59:34 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-keystoneclient/ChangeLog,v 1.15 2013/09/13 19:40:27 prometheanfire Exp $
+
+ 13 Sep 2013; Matthew Thode <prometheanfire@gentoo.org>
+ python-keystoneclient-9999.ebuild:
+ updating deps and stuff for distutils-r1
20 Aug 2013; Matthew Thode <prometheanfire@gentoo.org>
python-keystoneclient-0.3.1.ebuild:
diff --git a/dev-python/python-keystoneclient/python-keystoneclient-9999.ebuild b/dev-python/python-keystoneclient/python-keystoneclient-9999.ebuild
index fba93c540fac..895d6b4253f7 100644
--- a/dev-python/python-keystoneclient/python-keystoneclient-9999.ebuild
+++ b/dev-python/python-keystoneclient/python-keystoneclient-9999.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-keystoneclient/python-keystoneclient-9999.ebuild,v 1.4 2013/03/26 06:09:02 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-keystoneclient/python-keystoneclient-9999.ebuild,v 1.5 2013/09/13 19:40:27 prometheanfire Exp $
EAPI=5
#restricted due to packages missing and bad depends in the test ==webob-1.0.8
RESTRICT="test"
+#PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
PYTHON_COMPAT=( python2_7 )
-inherit git-2 distutils-r1
+inherit distutils-r1 git-2
DESCRIPTION="A client for the OpenStack Keystone API"
HOMEPAGE="https://github.com/openstack/python-keystoneclient"
@@ -15,7 +16,7 @@ EGIT_REPO_URI="https://github.com/openstack/python-keystoneclient.git"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS=""
+KEYWORDS="~amd64 ~x86"
IUSE="test"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
@@ -29,18 +30,28 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/nose-exclude[${PYTHON_USEDEP}]
dev-python/nosehtmloutput[${PYTHON_USEDEP}]
dev-python/openstack-nose-plugin[${PYTHON_USEDEP}]
- =dev-python/pep8-1.3.3
+ =dev-python/pep8-1.4.5[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
>=dev-python/testtools-0.9.22[${PYTHON_USEDEP}]
dev-python/unittest2[${PYTHON_USEDEP}]
- =dev-python/webob-1.0.8 )"
-RDEPEND="dev-python/iso8601[${PYTHON_USEDEP}]
- dev-python/prettytable
- >=dev-python/requests-0.8.8
- <=dev-python/requests-1.0
+ >=dev-python/webob-1.0.8[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/d2to1-0.2.10[${PYTHON_USEDEP}]
+ <dev-python/d2to1-0.3[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.5[${PYTHON_USEDEP}]
+ <dev-python/pbr-0.6[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.6[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/requests-0.8.8[${PYTHON_USEDEP}]
dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
virtual/python-argparse[${PYTHON_USEDEP}]"
+PATCHES=(
+)
+# "${FILESDIR}/0.2.3-CVE-2013-2104.patch"
+
python_test() {
${PYTHON} setup.py nosetests || die
}