summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-13 00:46:07 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-13 00:46:07 +0000
commit28f1795eca423acf8206a09f0325ed177b8a92bf (patch)
treea57e13652142eb9fecac541c4d51a921f27b79db /dev-python/python-gnutls
parentUpdate named.ca. Removed proc mount. (diff)
downloadgentoo-2-28f1795eca423acf8206a09f0325ed177b8a92bf.tar.gz
gentoo-2-28f1795eca423acf8206a09f0325ed177b8a92bf.tar.bz2
gentoo-2-28f1795eca423acf8206a09f0325ed177b8a92bf.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
(Portage version: 14014-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-gnutls')
-rw-r--r--dev-python/python-gnutls/ChangeLog8
-rw-r--r--dev-python/python-gnutls/python-gnutls-1.1.9.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/python-gnutls/ChangeLog b/dev-python/python-gnutls/ChangeLog
index d6fb1b33c4c6..5e8b020c7b18 100644
--- a/dev-python/python-gnutls/ChangeLog
+++ b/dev-python/python-gnutls/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-gnutls
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-gnutls/ChangeLog,v 1.1 2009/04/25 10:53:00 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-gnutls/ChangeLog,v 1.2 2009/08/13 00:46:07 arfrever Exp $
+
+*python-gnutls-1.1.9 (13 Aug 2009)
+
+ 13 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +python-gnutls-1.1.9.ebuild:
+ Version bump. Set SUPPORT_PYTHON_ABIS.
*python-gnutls-1.1.8 (25 Apr 2009)
diff --git a/dev-python/python-gnutls/python-gnutls-1.1.9.ebuild b/dev-python/python-gnutls/python-gnutls-1.1.9.ebuild
new file mode 100644
index 000000000000..9e1fd67cdfbb
--- /dev/null
+++ b/dev-python/python-gnutls/python-gnutls-1.1.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-gnutls/python-gnutls-1.1.9.ebuild,v 1.1 2009/08/13 00:46:07 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Python bindings for GnuTLS"
+HOMEPAGE="http://pypi.python.org/pypi/python-gnutls http://ag-projects.com/"
+SRC_URI="http://pypi.python.org/packages/source/p/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="net-libs/gnutls"
+RDEPEND="${DEPEND}"
+
+RESTRICT_PYTHON_ABIS="3*"
+
+PYTHON_MODNAME="gnutls"
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}