summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2008-05-25 16:32:09 +0000
committerLuca Longinotti <chtekk@gentoo.org>2008-05-25 16:32:09 +0000
commit17e714fbd01ddde2d2af0527ad835fc8f8bf07ac (patch)
tree5eaccaa5d94b644dc680a36032d388359797ecd9 /dev-python/python-fastcgi
parentStable for HPPA (bug #223017). (diff)
downloadgentoo-2-17e714fbd01ddde2d2af0527ad835fc8f8bf07ac.tar.gz
gentoo-2-17e714fbd01ddde2d2af0527ad835fc8f8bf07ac.tar.bz2
gentoo-2-17e714fbd01ddde2d2af0527ad835fc8f8bf07ac.zip
Initial release.
(Portage version: 2.1.5.2)
Diffstat (limited to 'dev-python/python-fastcgi')
-rw-r--r--dev-python/python-fastcgi/ChangeLog11
-rw-r--r--dev-python/python-fastcgi/Manifest5
-rw-r--r--dev-python/python-fastcgi/files/python-fastcgi-1.1-setup.patch40
-rw-r--r--dev-python/python-fastcgi/metadata.xml9
-rw-r--r--dev-python/python-fastcgi/python-fastcgi-1.1.ebuild27
5 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/python-fastcgi/ChangeLog b/dev-python/python-fastcgi/ChangeLog
new file mode 100644
index 000000000000..f13c745afded
--- /dev/null
+++ b/dev-python/python-fastcgi/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-python/python-fastcgi
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-fastcgi/ChangeLog,v 1.1 2008/05/25 16:32:09 chtekk Exp $
+
+*python-fastcgi-1.1 (25 May 2008)
+
+ 25 May 2008; Luca Longinotti <chtekk@gentoo.org>
+ +files/python-fastcgi-1.1-setup.patch, +metadata.xml,
+ +python-fastcgi-1.1.ebuild:
+ Initial release.
+
diff --git a/dev-python/python-fastcgi/Manifest b/dev-python/python-fastcgi/Manifest
new file mode 100644
index 000000000000..31a24a471144
--- /dev/null
+++ b/dev-python/python-fastcgi/Manifest
@@ -0,0 +1,5 @@
+AUX python-fastcgi-1.1-setup.patch 1660 RMD160 bb6d52bd9967e48e7a53d8c703e9c887bfe69d9e SHA1 33f4d00f133c0e98dcd222df7540e236cfdcdeb2 SHA256 6803b6ca66cc4a68bc3ef554ff7df32928ef63a0248073d0d3743a1eaad80bb7
+DIST python-fastcgi-1.1.tar.gz 11180 RMD160 609d71d65e52978eec94aca7b790f4d343092826 SHA1 6e206587f7ec85de9a0eaa06c9646d13b8585fe8 SHA256 3dff515aecbda371fe5bcb4e449109ce72120ce7bb1edd0e7c2138e75528fd12
+EBUILD python-fastcgi-1.1.ebuild 572 RMD160 51541a8b01ebd667377aa9bd91410143f24288ee SHA1 f80ec0044696fdc5caa366b5bbf4f2ead1acbab5 SHA256 fc57efa57870a2426841eade08efbc9cb514d994913ca64bf0c2de0d711a969f
+MISC ChangeLog 318 RMD160 0dec1a44186e284e4be7fd37a6cf8fddd70d3049 SHA1 fec2846e596901bf116b1ea752b95813b5c85ec1 SHA256 49afc0efeb30aca4f13cad1ff59eee7aa880d148bee1410bda289a4457e96e66
+MISC metadata.xml 250 RMD160 f92c7f884884f2b3b69da1a22a78143e2f8a3036 SHA1 3370464dbb63928007eaaacd244d8ebbe86b9f7b SHA256 c9fa4d069458afe15eef8fc56abc7a739ba006da363c72aaeaa5dfddf92ffd94
diff --git a/dev-python/python-fastcgi/files/python-fastcgi-1.1-setup.patch b/dev-python/python-fastcgi/files/python-fastcgi-1.1-setup.patch
new file mode 100644
index 000000000000..d565dda17c93
--- /dev/null
+++ b/dev-python/python-fastcgi/files/python-fastcgi-1.1-setup.patch
@@ -0,0 +1,40 @@
+--- setup.py 2005-12-15 07:41:42.000000000 +0100
++++ setup.py 2008-05-25 18:10:01.461135391 +0200
+@@ -1,18 +1,12 @@
+-#from distutils.core import setup, Extension
+-from ez_setup import use_setuptools
+-use_setuptools()
+-from setuptools import setup, Extension
++#!/usr/bin/env python
+
++from distutils import core
++from distutils.extension import Extension
+
+-c_ext = Extension("fcgi", ["fastcgi/pyfcgi.c"], libraries=["fcgi"],
+- include_dirs=["/usr/local/include"],
+- library_dirs=["/usr/local/lib"],
+- #extra_link_args=["-s"],
+- )
+-
+-setup(name="python-fastcgi",
++core.setup(
++ name="python-fastcgi",
+ version="1.1",
+- description="Python wrapper for the Open Market FastCGI library",
++ description="Python wrapper for the Open Market FastCGI library.",
+ long_description="python-fastcgi is a lightweight wrapper around the Open Market FastCGI C Library/SDK. It includes threaded and forking WSGI 1.0 server implementations.",
+ author="Cody Pisto",
+ author_email="cody@hpcs.com",
+@@ -26,9 +20,7 @@
+ "Programming Language :: C",
+ "Topic :: Internet :: WWW/HTTP :: Dynamic Content :: CGI Tools/Libraries",
+ "Topic :: Software Development :: Libraries :: Python Modules"],
+- packages=["fastcgi"],
+- #data_files=[("share/doc/python-fastcgi/example", ["example/test.fcgi"])],
++ packages=['fastcgi'],
+ ext_package='fastcgi',
+- ext_modules=[c_ext],
+- zip_safe=False,
+- )
++ ext_modules=[Extension(name='fcgi', sources=['fastcgi/pyfcgi.c'], libraries=['fcgi'])],
++)
diff --git a/dev-python/python-fastcgi/metadata.xml b/dev-python/python-fastcgi/metadata.xml
new file mode 100644
index 000000000000..aaad2869acbc
--- /dev/null
+++ b/dev-python/python-fastcgi/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<maintainer>
+ <email>chtekk@gentoo.org</email>
+ <name>Luca Longinotti</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-python/python-fastcgi/python-fastcgi-1.1.ebuild b/dev-python/python-fastcgi/python-fastcgi-1.1.ebuild
new file mode 100644
index 000000000000..7326200a08b7
--- /dev/null
+++ b/dev-python/python-fastcgi/python-fastcgi-1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-fastcgi/python-fastcgi-1.1.ebuild,v 1.1 2008/05/25 16:32:09 chtekk Exp $
+
+NEED_PYTHON=2.3
+
+inherit distutils eutils
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Interface to OpenMarket's FastCGI C Library/SDK."
+HOMEPAGE="http://pypi.python.org/pypi/${PN}/"
+SRC_URI="http://cheeseshop.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=dev-libs/fcgi-2.4.0-r2"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+src_unpack() {
+ distutils_src_unpack
+
+ epatch "${FILESDIR}"/${P}-setup.patch
+}