summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-21 12:57:58 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-21 12:57:58 +0000
commitc162eb46bea3ff01bc98f57b04e3eed611509cc5 (patch)
tree02d2e9215861f11b3e53220ce9fb8f0cc1e0142b /dev-python/python-docs
parentDelete older ebuilds. (diff)
downloadgentoo-2-c162eb46bea3ff01bc98f57b04e3eed611509cc5.tar.gz
gentoo-2-c162eb46bea3ff01bc98f57b04e3eed611509cc5.tar.bz2
gentoo-2-c162eb46bea3ff01bc98f57b04e3eed611509cc5.zip
Version bump.
(Portage version: 2.2.0_alpha24_p17/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-docs')
-rw-r--r--dev-python/python-docs/ChangeLog9
-rw-r--r--dev-python/python-docs/python-docs-3.2.ebuild39
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/python-docs/ChangeLog b/dev-python/python-docs/ChangeLog
index fac6edec2f83..c50f6299f7d3 100644
--- a/dev-python/python-docs/ChangeLog
+++ b/dev-python/python-docs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/python-docs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/ChangeLog,v 1.156 2011/02/20 16:36:46 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/ChangeLog,v 1.157 2011/02/21 12:57:58 arfrever Exp $
+
+*python-docs-3.2 (21 Feb 2011)
+
+ 21 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -python-docs-2.6.4.ebuild, -python-docs-2.6.5.ebuild,
+ -python-docs-3.1.2.ebuild, +python-docs-3.2.ebuild:
+ Version bump.
20 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
python-docs-2.6.6.ebuild, python-docs-2.7.1.ebuild, python-docs-3.1.3.ebuild:
diff --git a/dev-python/python-docs/python-docs-3.2.ebuild b/dev-python/python-docs/python-docs-3.2.ebuild
new file mode 100644
index 000000000000..40894b7ad641
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-3.2.ebuild,v 1.1 2011/02/21 12:57:58 arfrever Exp $
+
+EAPI="3"
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="http://www.python.org/doc/"
+SRC_URI="http://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+
+LICENSE="PSF-2.2"
+SLOT="3.2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/python-${PV}-docs-html"
+
+pkg_setup() {
+ if has_version "=dev-lang/python-3.2_pre*[doc]"; then
+ rm -f "${EROOT}etc/env.d/60python-docs-3.2"
+ fi
+}
+
+src_install() {
+ docinto html
+ cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html"
+
+ echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}"
+ doenvd "60python-docs-${SLOT}"
+}
+
+pkg_postrm() {
+ if ! has_version "<dev-python/python-docs-${SLOT}_alpha" && ! has_version ">=dev-python/python-docs-${SLOT%.*}.$((${SLOT#*.}+1))_alpha"; then
+ rm -f "${EROOT}etc/env.d/65python-docs"
+ fi
+}