summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-09-13 19:26:45 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-09-13 19:26:45 +0000
commit2ccc24627744d3518288d8f70cc0063e19f7312c (patch)
tree8a05459ec268207ad8b1e44f6a6cdfc2e2d9ed53 /dev-python/python-cinderclient
parentfixing pyparsing dep (diff)
downloadgentoo-2-2ccc24627744d3518288d8f70cc0063e19f7312c.tar.gz
gentoo-2-2ccc24627744d3518288d8f70cc0063e19f7312c.tar.bz2
gentoo-2-2ccc24627744d3518288d8f70cc0063e19f7312c.zip
cinderclient is now distutils-r1 happy
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/python-cinderclient')
-rw-r--r--dev-python/python-cinderclient/ChangeLog9
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-1.0.4.ebuild37
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-1.0.5-r1.ebuild (renamed from dev-python/python-cinderclient/python-cinderclient-1.0.5.ebuild)6
3 files changed, 11 insertions, 41 deletions
diff --git a/dev-python/python-cinderclient/ChangeLog b/dev-python/python-cinderclient/ChangeLog
index 31a64969f723..f76311301cff 100644
--- a/dev-python/python-cinderclient/ChangeLog
+++ b/dev-python/python-cinderclient/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/python-cinderclient
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-cinderclient/ChangeLog,v 1.5 2013/08/11 02:19:22 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-cinderclient/ChangeLog,v 1.6 2013/09/13 19:26:45 prometheanfire Exp $
+
+*python-cinderclient-1.0.5-r1 (13 Sep 2013)
+
+ 13 Sep 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +python-cinderclient-1.0.5-r1.ebuild, -python-cinderclient-1.0.4.ebuild,
+ -python-cinderclient-1.0.5.ebuild:
+ cinderclient is now distutils-r1 happy
*python-cinderclient-1.0.5 (11 Aug 2013)
diff --git a/dev-python/python-cinderclient/python-cinderclient-1.0.4.ebuild b/dev-python/python-cinderclient/python-cinderclient-1.0.4.ebuild
deleted file mode 100644
index 0acd8aab8459..000000000000
--- a/dev-python/python-cinderclient/python-cinderclient-1.0.4.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-cinderclient/python-cinderclient-1.0.4.ebuild,v 1.1 2013/05/16 01:21:30 prometheanfire Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="A client for the OpenStack Cinder API"
-HOMEPAGE="https://launchpad.net/python-cinderclient"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/fixtures[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/nosehtmloutput[${PYTHON_USEDEP}]
- dev-python/nosexcover
- dev-python/openstack-nose-plugin[${PYTHON_USEDEP}]
- =dev-python/pep8-1.3.3
- >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- >=dev-python/testtools-0.9.22 )"
-RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.6[${PYTHON_USEDEP}]
- <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
- >=dev-python/requests-0.8[${PYTHON_USEDEP}]
- dev-python/simplejson[${PYTHON_USEDEP}]"
-
-python_test() {
- sh run_tests.sh -N -p -c
-}
diff --git a/dev-python/python-cinderclient/python-cinderclient-1.0.5.ebuild b/dev-python/python-cinderclient/python-cinderclient-1.0.5-r1.ebuild
index 2d87b705496a..116685674acf 100644
--- a/dev-python/python-cinderclient/python-cinderclient-1.0.5.ebuild
+++ b/dev-python/python-cinderclient/python-cinderclient-1.0.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-cinderclient/python-cinderclient-1.0.5.ebuild,v 1.1 2013/08/11 02:19:22 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-cinderclient/python-cinderclient-1.0.5-r1.ebuild,v 1.1 2013/09/13 19:26:45 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -23,9 +23,9 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/nosehtmloutput[${PYTHON_USEDEP}]
- dev-python/nosexcover
+ dev-python/nosexcover[${PYTHON_USEDEP}]
dev-python/openstack-nose-plugin[${PYTHON_USEDEP}]
- =dev-python/pep8-1.3.3
+ ~dev-python/pep8-1.4.5[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
>=dev-python/testtools-0.9.22 )"
RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]