summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-06-13 06:44:27 +0000
committerJustin Lecher <jlec@gentoo.org>2013-06-13 06:44:27 +0000
commita12b5950921765cd8da085fcb9ca20852463a8f1 (patch)
tree00951c2f8a16ab784e6eaae14ea0d64279ac60d1 /dev-python/python-biggles
parentBump (diff)
downloadgentoo-2-a12b5950921765cd8da085fcb9ca20852463a8f1.tar.gz
gentoo-2-a12b5950921765cd8da085fcb9ca20852463a8f1.tar.bz2
gentoo-2-a12b5950921765cd8da085fcb9ca20852463a8f1.zip
dev-python/python-biggles: Bump to EAPI=5 and distutils-r1.eclass
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'dev-python/python-biggles')
-rw-r--r--dev-python/python-biggles/ChangeLog10
-rw-r--r--dev-python/python-biggles/metadata.xml2
-rw-r--r--dev-python/python-biggles/python-biggles-1.6.6-r1.ebuild37
3 files changed, 46 insertions, 3 deletions
diff --git a/dev-python/python-biggles/ChangeLog b/dev-python/python-biggles/ChangeLog
index 28ccbd022918..14651cab753c 100644
--- a/dev-python/python-biggles/ChangeLog
+++ b/dev-python/python-biggles/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-biggles
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-biggles/ChangeLog,v 1.21 2012/02/23 05:48:17 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-biggles/ChangeLog,v 1.22 2013/06/13 06:44:27 jlec Exp $
+
+*python-biggles-1.6.6-r1 (13 Jun 2013)
+
+ 13 Jun 2013; Justin Lecher <jlec@gentoo.org> +python-biggles-1.6.6-r1.ebuild,
+ metadata.xml:
+ Bump to EAPI=5 and distutils-r1.eclass
23 Feb 2012; Patrick Lauer <patrick@gentoo.org> python-biggles-1.6.6.ebuild:
Restricting pypy and jython
diff --git a/dev-python/python-biggles/metadata.xml b/dev-python/python-biggles/metadata.xml
index de483c53568f..ee7e8b2450a8 100644
--- a/dev-python/python-biggles/metadata.xml
+++ b/dev-python/python-biggles/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>python</herd>
+ <herd>python</herd>
</pkgmetadata>
diff --git a/dev-python/python-biggles/python-biggles-1.6.6-r1.ebuild b/dev-python/python-biggles/python-biggles-1.6.6-r1.ebuild
new file mode 100644
index 000000000000..ee89a871fea4
--- /dev/null
+++ b/dev-python/python-biggles/python-biggles-1.6.6-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-biggles/python-biggles-1.6.6-r1.ebuild,v 1.1 2013/06/13 06:44:27 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+MY_PN="python2-biggles"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Python module for creating publication-quality 2D scientific plots"
+HOMEPAGE="http://biggles.sourceforge.net/"
+SRC_URI="mirror://sourceforge/biggles/${MY_P}.tar.gz"
+
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ media-libs/plotutils[X]
+ x11-libs/libSM
+ x11-libs/libXext"
+RDEPEND="${DEPEND}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /usr/share/${PN}/
+ doins -r examples
+}