summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-10-25 22:11:51 +0000
committerTim Harder <radhermit@gentoo.org>2014-10-25 22:11:51 +0000
commit8cbedd933a4b443d6c62c4518ea2be0fcd86c066 (patch)
treeb414a1c93248246249b5dade795ac59f4d4ce88d /dev-python/pytest
parentEAPI bump; add slot operator on Perl dependency (diff)
downloadgentoo-2-8cbedd933a4b443d6c62c4518ea2be0fcd86c066.tar.gz
gentoo-2-8cbedd933a4b443d6c62c4518ea2be0fcd86c066.tar.bz2
gentoo-2-8cbedd933a4b443d6c62c4518ea2be0fcd86c066.zip
Version bump, drop python3_2 support.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/ChangeLog7
-rw-r--r--dev-python/pytest/pytest-2.6.4.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-python/pytest/ChangeLog b/dev-python/pytest/ChangeLog
index 201d08de93dd..bbdb5b93b8e4 100644
--- a/dev-python/pytest/ChangeLog
+++ b/dev-python/pytest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pytest
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.103 2014/10/18 14:41:52 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.104 2014/10/25 22:11:51 radhermit Exp $
+
+*pytest-2.6.4 (25 Oct 2014)
+
+ 25 Oct 2014; Tim Harder <radhermit@gentoo.org> +pytest-2.6.4.ebuild:
+ Version bump, drop python3_2 support.
18 Oct 2014; Agostino Sarubbo <ago@gentoo.org> pytest-2.6.3.ebuild:
Stable for x86, wrt bug #524416
diff --git a/dev-python/pytest/pytest-2.6.4.ebuild b/dev-python/pytest/pytest-2.6.4.ebuild
new file mode 100644
index 000000000000..e614e2aa6ee0
--- /dev/null
+++ b/dev-python/pytest/pytest-2.6.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.6.4.ebuild,v 1.1 2014/10/25 22:11:51 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+inherit distutils-r1
+
+DESCRIPTION="py.test: simple powerful testing with Python"
+HOMEPAGE="http://pytest.org/ http://pypi.python.org/pypi/pytest"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+# When bumping, please check setup.py for the proper py version
+PY_VER="1.4.25"
+RDEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
+
+#pexpect dep based on https://bitbucket.org/hpk42/pytest/issue/386/tests-fail-with-pexpect-30
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_cond_dep 'dev-python/pexpect[${PYTHON_USEDEP}]' 'python*')
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Disable versioning of py.test script to avoid collision with
+ # versioning performed by the eclass.
+ sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
+ grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
+
+ # Prevent un-needed d'loading
+ sed -e "s/'sphinx.ext.intersphinx', //" -i doc/en/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ mkdir doc/en/.build || die
+ emake -C doc/en html
+ fi
+}
+
+python_test() {
+ "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py \
+ --ignore=doc/en/example/nonpython/test_simple.yml \
+ || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && dohtml -r doc/en/_build/html/
+ distutils-r1_python_install_all
+}