summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2011-09-11 04:40:35 +0000
committerMike Gilbert <floppym@gentoo.org>2011-09-11 04:40:35 +0000
commit71cdeffe68882d24501cc2830da956020c9b79a3 (patch)
tree4b7cb27b22ba392417af3975e4a281d56c06ab63 /dev-python/pytest
parentAdd oracle-jre-bin:1.7 to JRE virtual. (diff)
downloadgentoo-2-71cdeffe68882d24501cc2830da956020c9b79a3.tar.gz
gentoo-2-71cdeffe68882d24501cc2830da956020c9b79a3.tar.bz2
gentoo-2-71cdeffe68882d24501cc2830da956020c9b79a3.zip
Version bump. Clean out pyc files; bug 380275. Thanks to David Leverton for the suggestion.
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/ChangeLog8
-rw-r--r--dev-python/pytest/pytest-2.1.1.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-python/pytest/ChangeLog b/dev-python/pytest/ChangeLog
index 540700899eaa..5bf955db1ddb 100644
--- a/dev-python/pytest/ChangeLog
+++ b/dev-python/pytest/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pytest
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.32 2011/07/24 16:29:38 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.33 2011/09/11 04:40:35 floppym Exp $
+
+*pytest-2.1.1 (11 Sep 2011)
+
+ 11 Sep 2011; Mike Gilbert <floppym@gentoo.org> +pytest-2.1.1.ebuild:
+ Version bump. Clean out pyc files; bug 380275. Thanks to David Leverton for
+ the suggestion.
24 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> pytest-2.0.3.ebuild:
ppc/ppc64 stable wrt #373363
diff --git a/dev-python/pytest/pytest-2.1.1.ebuild b/dev-python/pytest/pytest-2.1.1.ebuild
new file mode 100644
index 000000000000..62f102fe0eeb
--- /dev/null
+++ b/dev-python/pytest/pytest-2.1.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.1.1.ebuild,v 1.1 2011/09/11 04:40:35 floppym Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="py.test: simple powerful testing with Python"
+HOMEPAGE="http://pytest.org/ http://pypi.python.org/pypi/pytest"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=">=dev-python/py-1.4.5"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+
+DOCS="CHANGELOG README.txt"
+PYTHON_MODNAME="pytest.py _pytest"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Disable versioning of py.test script to avoid collision with versioning performed by distutils_src_install().
+ sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="${S}/build-${PYTHON_ABI}/lib" "$(PYTHON)" "build-${PYTHON_ABI}/lib/pytest.py"
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/py.test"
+
+ # Bug 380275: Test suite pre-compiles modules
+ python_clean_installation_image -q
+}