summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-11-17 04:13:46 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-11-17 04:13:46 +0000
commit4d7b71fcfb4919bc4368b218ed77d0757ce86a16 (patch)
treed115d0d9d5dba1e3d7aba8c94602ef23f58f6e75 /dev-python/pytest
parentadding ~amd64-fbsd and ~hppa, forgot :D (diff)
downloadgentoo-2-4d7b71fcfb4919bc4368b218ed77d0757ce86a16.tar.gz
gentoo-2-4d7b71fcfb4919bc4368b218ed77d0757ce86a16.tar.bz2
gentoo-2-4d7b71fcfb4919bc4368b218ed77d0757ce86a16.zip
added pytest-2.4.2 with restricted tests due to upstream bug
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/ChangeLog5
-rw-r--r--dev-python/pytest/pytest-2.4.2.ebuild11
2 files changed, 13 insertions, 3 deletions
diff --git a/dev-python/pytest/ChangeLog b/dev-python/pytest/ChangeLog
index e043ef729044..5271980f0003 100644
--- a/dev-python/pytest/ChangeLog
+++ b/dev-python/pytest/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/pytest
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.80 2013/11/16 04:54:05 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.81 2013/11/17 04:13:46 prometheanfire Exp $
+
+ 17 Nov 2013; Matthew Thode <prometheanfire@gentoo.org> pytest-2.4.2.ebuild:
+ added pytest-2.4.2 with restricted tests due to upstream bug
16 Nov 2013; Mike Gilbert <floppym@gentoo.org> pytest-2.4.2.ebuild:
Ignore silly test_simple.yml file when running tests. Thanks to idella4 for
diff --git a/dev-python/pytest/pytest-2.4.2.ebuild b/dev-python/pytest/pytest-2.4.2.ebuild
index d589e8080914..8100eeafa737 100644
--- a/dev-python/pytest/pytest-2.4.2.ebuild
+++ b/dev-python/pytest/pytest-2.4.2.ebuild
@@ -1,12 +1,16 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.4.2.ebuild,v 1.2 2013/11/16 04:54:05 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.4.2.ebuild,v 1.3 2013/11/17 04:13:46 prometheanfire Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
inherit distutils-r1 eutils
+RESTRICT="test"
+#testing restricted due to test failures with pexpect-3.0 (which is required for pypy2_0 and python3_x support)
+#https://bitbucket.org/hpk42/pytest/issue/386/tests-fail-with-pexpect-30
+
DESCRIPTION="py.test: simple powerful testing with Python"
HOMEPAGE="http://pytest.org/ http://pypi.python.org/pypi/pytest"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
@@ -19,10 +23,13 @@ IUSE="doc test"
# When bumping, please check setup.py for the proper py version
PY_VER="1.4.17"
RDEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
+
+#pexpect dep based on https://bitbucket.org/hpk42/pytest/issue/386/tests-fail-with-pexpect-30
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
virtual/python-argparse[${PYTHON_USEDEP}]
- test? ( dev-python/pyyaml[${PYTHON_USEDEP}] )"
+ test? ( dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}] )"
python_prepare_all() {
# Disable versioning of py.test script to avoid collision with