summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-18 20:15:06 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-18 20:15:06 +0000
commit2b03d4bb875fc14a80779239097ea7497dfa15e8 (patch)
tree0e7588e6b4feb9950eb61e1e06b43c42c2edbc65 /dev-python/pytest
parentVersion bump. (diff)
downloadgentoo-2-2b03d4bb875fc14a80779239097ea7497dfa15e8.tar.gz
gentoo-2-2b03d4bb875fc14a80779239097ea7497dfa15e8.tar.bz2
gentoo-2-2b03d4bb875fc14a80779239097ea7497dfa15e8.zip
Version bump.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/ChangeLog8
-rw-r--r--dev-python/pytest/pytest-2.0.3.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/pytest/ChangeLog b/dev-python/pytest/ChangeLog
index c35d60ae51f8..0e7bef20252b 100644
--- a/dev-python/pytest/ChangeLog
+++ b/dev-python/pytest/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pytest
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.21 2011/04/18 19:56:19 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.22 2011/04/18 20:15:06 arfrever Exp $
+
+*pytest-2.0.3 (18 Apr 2011)
+
+ 18 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pytest-2.0.3.ebuild:
+ Version bump.
18 Apr 2011; Thomas Kahle <tomka@gentoo.org> pytest-2.0.2.ebuild:
x86 stable per bug 362773
diff --git a/dev-python/pytest/pytest-2.0.3.ebuild b/dev-python/pytest/pytest-2.0.3.ebuild
new file mode 100644
index 000000000000..582241f24ad6
--- /dev/null
+++ b/dev-python/pytest/pytest-2.0.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.0.3.ebuild,v 1.1 2011/04/18 20:15:06 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="py.test: simple powerful testing with Python"
+HOMEPAGE="http://pytest.org/ http://pypi.python.org/pypi/pytest"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=">=dev-python/py-1.4.3"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+
+DOCS="CHANGELOG README.txt"
+PYTHON_MODNAME="pytest.py _pytest"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Disable versioning of py.test script to avoid collision with versioning performed by distutils_src_install().
+ sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="${S}/build-${PYTHON_ABI}/lib" "$(PYTHON)" "build-${PYTHON_ABI}/lib/pytest.py"
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/py.test"
+}