summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-05-09 22:18:39 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-05-09 22:18:39 +0000
commit915296438f440c4d06d872d4ce2a7f83d245043d (patch)
tree569313609472679bf40944f2733092fa37d0b762 /dev-python/pyro
parentremove old. force due to unsynced tree (diff)
downloadgentoo-2-915296438f440c4d06d872d4ce2a7f83d245043d.tar.gz
gentoo-2-915296438f440c4d06d872d4ce2a7f83d245043d.tar.bz2
gentoo-2-915296438f440c4d06d872d4ce2a7f83d245043d.zip
Version bump.
(Portage version: 2.2.0_alpha32_p7/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyro')
-rw-r--r--dev-python/pyro/ChangeLog8
-rw-r--r--dev-python/pyro/pyro-3.13.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-python/pyro/ChangeLog b/dev-python/pyro/ChangeLog
index 476de0e33a98..8a3066b88dbf 100644
--- a/dev-python/pyro/ChangeLog
+++ b/dev-python/pyro/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyro
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.39 2011/04/26 18:49:53 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.40 2011/05/09 22:18:39 arfrever Exp $
+
+*pyro-3.13 (09 May 2011)
+
+ 09 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pyro-3.13.ebuild:
+ Version bump.
*pyro-4.4 (26 Apr 2011)
diff --git a/dev-python/pyro/pyro-3.13.ebuild b/dev-python/pyro/pyro-3.13.ebuild
new file mode 100644
index 000000000000..a1b78683bd9b
--- /dev/null
+++ b/dev-python/pyro/pyro-3.13.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-3.13.ebuild,v 1.1 2011/05/09 22:18:39 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit distutils
+
+MY_PN="Pyro"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Advanced and powerful Distributed Object Technology system written entirely in Python"
+HOMEPAGE="http://www.xs4all.nl/~irmen/pyro3/ http://pypi.python.org/pypi/Pyro"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+DEPEND="!dev-python/pyro:0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="Pyro"
+
+src_prepare() {
+ distutils_src_prepare
+ find examples -name "*.pyc" -print0 | xargs -0 rm -f
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/* || die "Installation of documentation failed"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "Installation of examples failed"
+ fi
+}