summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-11-08 23:04:06 +0000
committerMichał Górny <mgorny@gentoo.org>2014-11-08 23:04:06 +0000
commit01d03846604f46e98f2b6ec8c7d3fc3b7776fd77 (patch)
treea5ed7ddf47904ee21d011c0965e52e1ff974afcf /dev-python/pypy-bin
parentAdd binary version for boost-1.55 (diff)
downloadgentoo-2-01d03846604f46e98f2b6ec8c7d3fc3b7776fd77.tar.gz
gentoo-2-01d03846604f46e98f2b6ec8c7d3fc3b7776fd77.tar.bz2
gentoo-2-01d03846604f46e98f2b6ec8c7d3fc3b7776fd77.zip
Update and clean up the ebuild. Provide sane binary packages based on the revised version of dev-python/pypy.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/pypy-bin')
-rw-r--r--dev-python/pypy-bin/ChangeLog6
-rw-r--r--dev-python/pypy-bin/pypy-bin-2.4.0.ebuild77
2 files changed, 37 insertions, 46 deletions
diff --git a/dev-python/pypy-bin/ChangeLog b/dev-python/pypy-bin/ChangeLog
index c9c265f63067..6e4b7a801fa4 100644
--- a/dev-python/pypy-bin/ChangeLog
+++ b/dev-python/pypy-bin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pypy-bin
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pypy-bin/ChangeLog,v 1.26 2014/11/05 21:18:12 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pypy-bin/ChangeLog,v 1.27 2014/11/08 23:04:06 mgorny Exp $
+
+ 08 Nov 2014; Michał Górny <mgorny@gentoo.org> pypy-bin-2.4.0.ebuild:
+ Update and clean up the ebuild. Provide sane binary packages based on the
+ revised version of dev-python/pypy.
05 Nov 2014; Michał Górny <mgorny@gentoo.org> pypy-bin-2.3.1-r2.ebuild,
pypy-bin-2.4.0.ebuild:
diff --git a/dev-python/pypy-bin/pypy-bin-2.4.0.ebuild b/dev-python/pypy-bin/pypy-bin-2.4.0.ebuild
index 6c7e19734204..3e6a96a60a5e 100644
--- a/dev-python/pypy-bin/pypy-bin-2.4.0.ebuild
+++ b/dev-python/pypy-bin/pypy-bin-2.4.0.ebuild
@@ -1,66 +1,54 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pypy-bin/pypy-bin-2.4.0.ebuild,v 1.5 2014/11/05 21:18:12 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pypy-bin/pypy-bin-2.4.0.ebuild,v 1.6 2014/11/08 23:04:06 mgorny Exp $
EAPI=5
-PYTHON_COMPAT=( python2_7 pypy pypy2_0 )
-inherit eutils multilib pax-utils python-any-r1 vcs-snapshot versionator
+PYTHON_COMPAT=( python2_7 pypy )
+inherit eutils multilib pax-utils python-any-r1 versionator
-BINHOST="http://packages.gentooexperimental.org/pypy/"
-
-# x86 currently fails, so no pypy-bin yet
+BINHOST="http://dev.gentoo.org/~mgorny/dist/pypy-bin/${PV}"
DESCRIPTION="A fast, compliant alternative implementation of the Python language (binary package)"
HOMEPAGE="http://pypy.org/"
-SRC_URI="https://www.bitbucket.org/pypy/pypy/downloads/pypy-${PV}-src.tar.bz2
+SRC_URI="https://bitbucket.org/pypy/pypy/downloads/pypy-${PV}-src.tar.bz2
amd64? (
jit? ( shadowstack? (
${BINHOST}/${P}-amd64+bzip2+jit+ncurses+shadowstack.tar.xz
- -> ${P}-r1-amd64+bzip2+jit+ncurses+shadowstack.tar.xz
) )
jit? ( !shadowstack? (
${BINHOST}/${P}-amd64+bzip2+jit+ncurses.tar.xz
- -> ${P}-r1-amd64+bzip2+jit+ncurses.tar.xz
) )
!jit? ( !shadowstack? (
${BINHOST}/${P}-amd64+bzip2+ncurses.tar.xz
- -> ${P}-r1-amd64+bzip2+ncurses.tar.xz
) )
+ )
+ x86? (
+ sse2? (
+ jit? ( shadowstack? (
+ ${BINHOST}/${P}-x86+bzip2+jit+ncurses+shadowstack+sse2.tar.xz
+ ) )
+ jit? ( !shadowstack? (
+ ${BINHOST}/${P}-x86+bzip2+jit+ncurses+sse2.tar.xz
+ ) )
+ !jit? ( !shadowstack? (
+ ${BINHOST}/${P}-x86+bzip2+ncurses+sse2.tar.xz
+ ) )
+ )
+ !sse2? (
+ !jit? ( !shadowstack? (
+ ${BINHOST}/${P}-x86+bzip2+ncurses.tar.xz
+ ) )
+ )
)"
-# x86? (
-# sse2? (
-# jit? ( shadowstack? (
-# ${BINHOST}/${P}-x86+bzip2+jit+ncurses+shadowstack+sse2.tar.xz
-# -> ${P}-r1-x86+bzip2+jit+ncurses+shadowstack+sse2.tar.xz
-# ) )
-# jit? ( !shadowstack? (
-# ${BINHOST}/${P}-x86+bzip2+jit+ncurses+sse2.tar.xz
-# -> ${P}-r1-x86+bzip2+jit+ncurses+sse2.tar.xz
-# ) )
-# !jit? ( !shadowstack? (
-# ${BINHOST}/${P}-x86+bzip2+ncurses+sse2.tar.xz
-# -> ${P}-r1-x86+bzip2+ncurses+sse2.tar.xz
-# ) )
-# )
-# !sse2? (
-# !jit? ( !shadowstack? (
-# ${BINHOST}/${P}-x86+bzip2+ncurses.tar.xz
-# -> ${P}-r1-x86+bzip2+ncurses.tar.xz
-# ) )
-# )
-# )"
-
# Supported variants
REQUIRED_USE="!jit? ( !shadowstack )
x86? ( !sse2? ( !jit !shadowstack ) )"
LICENSE="MIT"
SLOT="0/$(get_version_component_range 1-2 ${PV})"
-#KEYWORDS="~amd64"
-# Needs some more sanity checks before it gets unleashed on users
-KEYWORDS=""
+KEYWORDS="~amd64 ~x86"
IUSE="doc gdbm +jit shadowstack sqlite sse2 test tk"
# yep, world would be easier if people started filling subslots...
@@ -92,8 +80,8 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}/1.9-scripts-location.patch"
- epatch "${FILESDIR}/1.9-distutils.unixccompiler.UnixCCompiler.runtime_library_dir_option.patch"
+ epatch "${FILESDIR}/1.9-scripts-location.patch" \
+ "${FILESDIR}/1.9-distutils.unixccompiler.UnixCCompiler.runtime_library_dir_option.patch"
pushd lib-python/2.7 > /dev/null || die
epatch "${FILESDIR}/2.3-21_all_distutils_c++.patch"
@@ -115,12 +103,12 @@ src_compile() {
}
# Doesn't work - pypy missing its own libs
-#src_test() {
-# # (unset)
-# local -x PYTHONDONTWRITEBYTECODE
-#
-# ./pypy-c ./pypy/test_all.py --pypy=./pypy-c lib-python || die
-#}
+src_test() {
+ # (unset)
+ local -x PYTHONDONTWRITEBYTECODE
+
+ ./pypy-c ./pypy/test_all.py --pypy=./pypy-c lib-python || die
+}
src_install() {
einfo "Installing PyPy ..."
@@ -129,7 +117,6 @@ src_install() {
fperms a+x ${INSDESTTREE}/pypy-c ${INSDESTTREE}/libpypy-c.so
pax-mark m "${ED%/}${INSDESTTREE}/pypy-c" "${ED%/}${INSDESTTREE}/libpypy-c.so"
dosym ../$(get_libdir)/pypy/pypy-c /usr/bin/pypy
- dosym ../$(get_libdir)/pypy/libpypy-c.so /usr/$(get_libdir)/libpypy-c.so
dodoc README.rst
if ! use gdbm; then