summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-02-16 13:40:39 +0000
committerIan Delaney <idella4@gentoo.org>2014-02-16 13:40:39 +0000
commitb6681d5bf2e239a55c1048a3a928b2cc60551927 (patch)
tree2c2b96c004536945d1aec01b51206f682666f8cd /dev-python/pyphen/pyphen-0.9.1.ebuild
parentMask net-analyzer/ethstatus (bug #501432). (diff)
downloadgentoo-2-b6681d5bf2e239a55c1048a3a928b2cc60551927.tar.gz
gentoo-2-b6681d5bf2e239a55c1048a3a928b2cc60551927.tar.bz2
gentoo-2-b6681d5bf2e239a55c1048a3a928b2cc60551927.zip
bump; add pypy support
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pyphen/pyphen-0.9.1.ebuild')
-rw-r--r--dev-python/pyphen/pyphen-0.9.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pyphen/pyphen-0.9.1.ebuild b/dev-python/pyphen/pyphen-0.9.1.ebuild
new file mode 100644
index 000000000000..702b51f09211
--- /dev/null
+++ b/dev-python/pyphen/pyphen-0.9.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyphen/pyphen-0.9.1.ebuild,v 1.1 2014/02/16 13:40:39 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for hyphenation using hunspell dictionaries"
+MY_PN="Pyphen"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+HOMEPAGE="https://github.com/Kozea/Pyphen"
+
+LICENSE="GPL-2+ LGPL-2+ MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"