summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-21 10:15:31 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-21 10:15:31 +0000
commit963da2715512020fa7f3fe99b5e06622c77c6a43 (patch)
tree8dcd2cdc982a80fab9729c1d8f02d1a978e7eaa3 /dev-python/pyparsing
parentAdd a version of 1.68 without built_with_use (diff)
downloadgentoo-2-963da2715512020fa7f3fe99b5e06622c77c6a43.tar.gz
gentoo-2-963da2715512020fa7f3fe99b5e06622c77c6a43.tar.bz2
gentoo-2-963da2715512020fa7f3fe99b5e06622c77c6a43.zip
Migrate to distutils-r1.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/pyparsing')
-rw-r--r--dev-python/pyparsing/ChangeLog7
-rw-r--r--dev-python/pyparsing/pyparsing-1.5.6-r2.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-python/pyparsing/ChangeLog b/dev-python/pyparsing/ChangeLog
index af0c6179cbf8..5a11cce2286c 100644
--- a/dev-python/pyparsing/ChangeLog
+++ b/dev-python/pyparsing/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyparsing
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparsing/ChangeLog,v 1.85 2012/11/26 08:01:29 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparsing/ChangeLog,v 1.86 2012/12/21 10:15:31 mgorny Exp $
+
+*pyparsing-1.5.6-r2 (21 Dec 2012)
+
+ 21 Dec 2012; Michał Górny <mgorny@gentoo.org> +pyparsing-1.5.6-r2.ebuild:
+ Migrate to distutils-r1.
*pyparsing-1.5.6-r1 (27 Nov 2012)
diff --git a/dev-python/pyparsing/pyparsing-1.5.6-r2.ebuild b/dev-python/pyparsing/pyparsing-1.5.6-r2.ebuild
new file mode 100644
index 000000000000..d2d00d37d1e2
--- /dev/null
+++ b/dev-python/pyparsing/pyparsing-1.5.6-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparsing/pyparsing-1.5.6-r2.ebuild,v 1.1 2012/12/21 10:15:31 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_8,1_9} )
+
+inherit distutils-r1
+
+DESCRIPTION="pyparsing is an easy-to-use Python module for text parsing"
+HOMEPAGE="http://pyparsing.wikispaces.com/ http://pypi.python.org/pypi/pyparsing"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+
+# Build system copies the module from py2/py3 version to the regular
+# name before installing.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # resorted to sed, fixed in June upstream, bug ID: 3381439.
+ # See Bug #443836.
+ sed -e "s/26 June 2011 10:53/16 June 2012 03:08/" \
+ -e 's:exc.__traceback__:pe.__traceback__:' \
+ -i pyparsing_py3.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ local HTML_DOCS=( HowToUsePyparsing.html )
+
+ distutils-r1_python_install_all
+
+ insinto /usr/share/doc/${PF}
+
+ if use doc; then
+ dohtml -r htmldoc/*
+ doins docs/*.pdf
+ fi
+
+ if use examples; then
+ doins -r examples
+ fi
+}