summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-02-16 19:36:32 +0000
committerJustin Lecher <jlec@gentoo.org>2012-02-16 19:36:32 +0000
commit0aa37c36b4c64a665e3fde7ab36657d31949b847 (patch)
tree1005009067f1388818479ede57c010acc98ba9d8 /dev-python/pympler
parentx86 stable wrt bug #397279 (diff)
downloadgentoo-2-0aa37c36b4c64a665e3fde7ab36657d31949b847.tar.gz
gentoo-2-0aa37c36b4c64a665e3fde7ab36657d31949b847.tar.bz2
gentoo-2-0aa37c36b4c64a665e3fde7ab36657d31949b847.zip
Initial commit written by me
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pympler')
-rw-r--r--dev-python/pympler/ChangeLog10
-rw-r--r--dev-python/pympler/Manifest4
-rw-r--r--dev-python/pympler/metadata.xml15
-rw-r--r--dev-python/pympler/pympler-0.2.0.ebuild27
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pympler/ChangeLog b/dev-python/pympler/ChangeLog
new file mode 100644
index 000000000000..4d87ab1edca4
--- /dev/null
+++ b/dev-python/pympler/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/pympler
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pympler/ChangeLog,v 1.1 2012/02/16 19:36:32 jlec Exp $
+
+*pympler-0.2.0 (16 Feb 2012)
+
+ 16 Feb 2012; Justin Lecher <jlec@gentoo.org> +pympler-0.2.0.ebuild,
+ +metadata.xml:
+ Initial commit written by me
+
diff --git a/dev-python/pympler/Manifest b/dev-python/pympler/Manifest
new file mode 100644
index 000000000000..0f6b071486d7
--- /dev/null
+++ b/dev-python/pympler/Manifest
@@ -0,0 +1,4 @@
+DIST pympler-0.2.0.tar.xz 206996 RMD160 165eebbd110c5efeef1d2643c4db42c77ceb002f SHA1 3d6936549b0196fd9a03221d5fc0ea9dc00e767b SHA256 c2c52a7f6126a11b982d4fb6096f261c4aea6a1f38e4ab36329d025d3eeac56e
+EBUILD pympler-0.2.0.ebuild 640 RMD160 e093ad484c5ae58a80f7cdc83a2725970b4d31b0 SHA1 39342cfdbf22b7d034f398bde375644d3cb58d23 SHA256 86271c765505ff2ea3ed43478edf0f95187482a7382c700f40ec126b7e556fe5
+MISC ChangeLog 268 RMD160 9fc2f66bb062eb8e02248ea706b46ab3d9538864 SHA1 51de2e667646d5e289af1d2e21edd9601d755c35 SHA256 131cb4bb2ad34d24ae82dfa27e0a52feeb6d060aa49531cdedb0f268296ca573
+MISC metadata.xml 619 RMD160 35a55730633fb10a6e86acfdd572271e81162e90 SHA1 240d07d3cc218661e04262334996ca32af346f3c SHA256 a1420ea0d9131fb6a619769e6bb18adeff76870a506e09db220fe1df738198e2
diff --git a/dev-python/pympler/metadata.xml b/dev-python/pympler/metadata.xml
new file mode 100644
index 000000000000..29586bc1dc24
--- /dev/null
+++ b/dev-python/pympler/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+Pympler is a development tool to measure, monitor and analyze the memory
+behavior of Python objects in a running Python application. By pympling a
+Python application, detailed insight in the size and the lifetime of Python
+objects can be obtained. Undesirable or unexpected runtime behavior like
+memory bloat and other "pymples" can easily be identified.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/pympler/pympler-0.2.0.ebuild b/dev-python/pympler/pympler-0.2.0.ebuild
new file mode 100644
index 000000000000..0813eb40e71e
--- /dev/null
+++ b/dev-python/pympler/pympler-0.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pympler/pympler-0.2.0.ebuild,v 1.1 2012/02/16 19:36:32 jlec Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="memory profiling for Python applications"
+HOMEPAGE="http://code.google.com/p/pympler/"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="Apache-2.0"
+IUSE=""
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" setup.py test
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" run.py --test --clean
+ }
+ python_execute_function testing
+}