summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-08-27 08:36:01 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-08-27 08:36:01 +0000
commitf8896542463b169f36a4692d2f3db2b5e67d0085 (patch)
tree713c80a5f14ba87634392d6cd5be7fc078d7ee3c /dev-python/pylint
parenthard-code EDITOR in init scripts wrt #432606. (diff)
downloadgentoo-2-f8896542463b169f36a4692d2f3db2b5e67d0085.tar.gz
gentoo-2-f8896542463b169f36a4692d2f3db2b5e67d0085.tar.bz2
gentoo-2-f8896542463b169f36a4692d2f3db2b5e67d0085.zip
Bump for #432532
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/ChangeLog8
-rw-r--r--dev-python/pylint/pylint-0.25.2.ebuild61
2 files changed, 67 insertions, 2 deletions
diff --git a/dev-python/pylint/ChangeLog b/dev-python/pylint/ChangeLog
index ef572f047246..2f77c787cb02 100644
--- a/dev-python/pylint/ChangeLog
+++ b/dev-python/pylint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pylint
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.86 2012/02/08 04:52:28 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.87 2012/08/27 08:36:01 patrick Exp $
+
+*pylint-0.25.2 (27 Aug 2012)
+
+ 27 Aug 2012; Patrick Lauer <patrick@gentoo.org> +pylint-0.25.2.ebuild:
+ Bump for #432532
*pylint-0.25.1 (08 Feb 2012)
@@ -373,4 +378,3 @@
14 Oct 2003; Alastair Tse <liquidx@gentoo.org> pylint-0.2.1.ebuild:
initial ebuild. python syntax checker
-
diff --git a/dev-python/pylint/pylint-0.25.2.ebuild b/dev-python/pylint/pylint-0.25.2.ebuild
new file mode 100644
index 000000000000..abc2a365e774
--- /dev/null
+++ b/dev-python/pylint/pylint-0.25.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.25.2.ebuild,v 1.1 2012/08/27 08:36:01 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4"
+
+inherit distutils
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="http://www.logilab.org/projects/pylint/ http://pypi.python.org/pypi/pylint"
+SRC_URI="ftp://ftp.logilab.org/pub/${PN}/${P}.tar.gz mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="examples"
+
+# Versions specified in __pkginfo__.py.
+RDEPEND=">=dev-python/logilab-common-0.53.0
+ >=dev-python/astng-0.21.1"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+DOCS="doc/*.txt"
+
+src_test() {
+ testing() {
+ # Test suite broken with Python 3.
+ [[ "${PYTHON_ABI}" == 3.* ]] && return
+
+ PYTHONPATH="build/lib" pytest -v
+ }
+ python_execute_function -s testing
+}
+
+src_install() {
+ distutils_src_install
+
+ doman man/{pylint,pyreverse}.1 || die "doman failed"
+
+ if use examples; then
+ docinto examples
+ dodoc examples/* || die "dodoc failed"
+ fi
+
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/pylint/test"
+ }
+ python_execute_function -q delete_tests
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ # Optional dependency on "tk" USE flag would break support for Jython.
+ elog "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled."
+}