summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-15 10:39:06 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-15 10:39:06 +0000
commit8283e35b0fe8f2b78bfa11e97d4999dd47702235 (patch)
treed28c03501787c5ba80b72e1b6302e9fff4636818 /dev-python/pylint/pylint-0.28.0.ebuild
parentVersion bump (diff)
downloadgentoo-2-8283e35b0fe8f2b78bfa11e97d4999dd47702235.tar.gz
gentoo-2-8283e35b0fe8f2b78bfa11e97d4999dd47702235.tar.bz2
gentoo-2-8283e35b0fe8f2b78bfa11e97d4999dd47702235.zip
add missing dep, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pylint/pylint-0.28.0.ebuild')
-rw-r--r--dev-python/pylint/pylint-0.28.0.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/pylint/pylint-0.28.0.ebuild b/dev-python/pylint/pylint-0.28.0.ebuild
deleted file mode 100644
index a85248a952fb..000000000000
--- a/dev-python/pylint/pylint-0.28.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.28.0.ebuild,v 1.5 2013/09/26 15:51:22 jlec Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="http://www.logilab.org/project/pylint http://pypi.python.org/pypi/pylint"
-SRC_URI="ftp://ftp.logilab.org/pub/${PN}/${P}.tar.gz mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="examples"
-
-# Versions specified in __pkginfo__.py.
-RDEPEND=">=dev-python/logilab-common-0.53.0[${PYTHON_USEDEP}]
- >=dev-python/astng-0.24.3[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-PATCHES=( "${FILESDIR}"/${PN}-0.26.0-gtktest.patch )
-
-python_test() {
- # Test suite broken with Python 3
- local msg="Test suite broken with ${EPYTHON}"
- if [[ "${EPYTHON}" == python3* ]]; then
- einfo "${msg}"
- else
- # https://bitbucket.org/logilab/pylint/issue/11/apparent-regression-in-testsuite-pylint
- # This 'issue' became' declared fixed by accident for version 0.27.0 despite being made citing 0.28.0
- pytest || die "Tests failed under ${EPYTHON}"
- fi
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- doman man/{pylint,pyreverse}.1
-
- if use examples; then
- docinto examples
- dodoc examples/*
- fi
-}
-
-pkg_postinst() {
- # Optional dependency on "tk" USE flag would break support for Jython.
- elog "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled."
-}