summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2004-07-22 06:32:24 +0000
committerRob Cakebread <pythonhead@gentoo.org>2004-07-22 06:32:24 +0000
commit044ab0ae9d301ef2931ff60810cf63f037e836b9 (patch)
tree770228845b04f52e57ec57a4a83b0a6c17434362 /dev-python/pydispatcher
parentFixed libcurl version dependancy issue. Fixes Bug #57672 (Manifest recommit) (diff)
downloadgentoo-2-044ab0ae9d301ef2931ff60810cf63f037e836b9.tar.gz
gentoo-2-044ab0ae9d301ef2931ff60810cf63f037e836b9.tar.bz2
gentoo-2-044ab0ae9d301ef2931ff60810cf63f037e836b9.zip
New package. Thanks Mike Fletcher for the submission. bug# 54860
Diffstat (limited to 'dev-python/pydispatcher')
-rw-r--r--dev-python/pydispatcher/ChangeLog10
-rw-r--r--dev-python/pydispatcher/Manifest4
-rw-r--r--dev-python/pydispatcher/files/digest-pydispatcher-1.0.01
-rw-r--r--dev-python/pydispatcher/metadata.xml5
-rw-r--r--dev-python/pydispatcher/pydispatcher-1.0.0.ebuild27
5 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pydispatcher/ChangeLog b/dev-python/pydispatcher/ChangeLog
new file mode 100644
index 000000000000..eb42dd386a26
--- /dev/null
+++ b/dev-python/pydispatcher/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/pydispatcher
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pydispatcher/ChangeLog,v 1.1 2004/07/22 06:32:24 pythonhead Exp $
+
+*pydispatcher-1.0.0 (21 Jul 2004)
+
+ 21 Jul 2004; Rob Cakebread <pythonhead@gentoo.org> +metadata.xml,
+ +pydispatcher-1.0.0.ebuild:
+ New package. Thanks Mike Fletcher for the submission. bug# 54860
+
diff --git a/dev-python/pydispatcher/Manifest b/dev-python/pydispatcher/Manifest
new file mode 100644
index 000000000000..d77fac26e568
--- /dev/null
+++ b/dev-python/pydispatcher/Manifest
@@ -0,0 +1,4 @@
+MD5 69c12f55309f26a1a94f8d9f920d7a83 pydispatcher-1.0.0.ebuild 656
+MD5 2a86b25b37ee0d26eb5b30ce68fbdd27 metadata.xml 158
+MD5 4bf7360c736cffc80f8fd7c31dffcfb0 ChangeLog 325
+MD5 112d0f90d5bde3dabf675e265f5fb570 files/digest-pydispatcher-1.0.0 69
diff --git a/dev-python/pydispatcher/files/digest-pydispatcher-1.0.0 b/dev-python/pydispatcher/files/digest-pydispatcher-1.0.0
new file mode 100644
index 000000000000..bb26e4a43f94
--- /dev/null
+++ b/dev-python/pydispatcher/files/digest-pydispatcher-1.0.0
@@ -0,0 +1 @@
+MD5 cb1bcca0744549d76f93a26f0c1b4bb4 PyDispatcher-1.0.0.tar.gz 32891
diff --git a/dev-python/pydispatcher/metadata.xml b/dev-python/pydispatcher/metadata.xml
new file mode 100644
index 000000000000..b3f00ab1b1ec
--- /dev/null
+++ b/dev-python/pydispatcher/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata> \ No newline at end of file
diff --git a/dev-python/pydispatcher/pydispatcher-1.0.0.ebuild b/dev-python/pydispatcher/pydispatcher-1.0.0.ebuild
new file mode 100644
index 000000000000..0170da6a0f57
--- /dev/null
+++ b/dev-python/pydispatcher/pydispatcher-1.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pydispatcher/pydispatcher-1.0.0.ebuild,v 1.1 2004/07/22 06:32:24 pythonhead Exp $
+
+inherit distutils
+
+MY_PN="PyDispatcher"
+
+DESCRIPTION="Multi-producer-multi-consumer signal dispatching mechanism for Python"
+HOMEPAGE="http://pydispatcher.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+DEPEND="virtual/python"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+ distutils_src_install
+ distutils_python_version
+ dohtml -r ${D}/usr/lib/python${PYVER}/site-packages/dispatch/docs/*
+ rm -r ${D}/usr/lib/python${PYVER}/site-packages/dispatch/docs
+} \ No newline at end of file