summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-08-04 11:51:30 +0000
committerAlex Alexander <wired@gentoo.org>2009-08-04 11:51:30 +0000
commit97cfd73c08b1ecefbf96ce244f44b9dd938ae91e (patch)
treec9d69548ca78d8756e1f76d2a0a0f520a05724bd /dev-python/pycups
parentDon't use make and pass ${MAKEOPTS} and ${EXTRA_EMAKE} later. (diff)
downloadgentoo-2-97cfd73c08b1ecefbf96ce244f44b9dd938ae91e.tar.gz
gentoo-2-97cfd73c08b1ecefbf96ce244f44b9dd938ae91e.tar.bz2
gentoo-2-97cfd73c08b1ecefbf96ce244f44b9dd938ae91e.zip
version bump, ebuild from kde-testing
(Portage version: 2.2_rc35/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pycups')
-rw-r--r--dev-python/pycups/ChangeLog7
-rw-r--r--dev-python/pycups/pycups-1.9.46.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/pycups/ChangeLog b/dev-python/pycups/ChangeLog
index 2b2c36d70d85..b4a63fc450ff 100644
--- a/dev-python/pycups/ChangeLog
+++ b/dev-python/pycups/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pycups
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycups/ChangeLog,v 1.4 2009/06/12 14:06:09 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycups/ChangeLog,v 1.5 2009/08/04 11:51:30 wired Exp $
+
+*pycups-1.9.46 (04 Aug 2009)
+
+ 04 Aug 2009; Alex Alexander <wired@gentoo.org> +pycups-1.9.46.ebuild:
+ version bump, ebuild from kde-testing
*pycups-1.9.45-r1 (12 Jun 2009)
diff --git a/dev-python/pycups/pycups-1.9.46.ebuild b/dev-python/pycups/pycups-1.9.46.ebuild
new file mode 100644
index 000000000000..10279476c27c
--- /dev/null
+++ b/dev-python/pycups/pycups-1.9.46.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycups/pycups-1.9.46.ebuild,v 1.1 2009/08/04 11:51:30 wired Exp $
+
+NEED_PYTHON="2.4"
+inherit distutils flag-o-matic
+
+DESCRIPTION="Python bindings for the CUPS API"
+HOMEPAGE="http://cyberelk.net/tim/data/pycups/"
+SRC_URI="http://cyberelk.net/tim/data/pycups/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ net-print/cups
+"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/epydoc )
+"
+
+src_compile() {
+ append-cflags -DVERSION=\\\"${PV}\\\"
+ distutils_src_compile
+
+ if use doc; then
+ emake doc || die "emake doc failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r html/ || die "installing html docs failed"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/"${P}"
+ doins -r examples/ || die "installing examples failed"
+ fi
+
+}