summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-05-22 07:28:51 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-05-22 07:28:51 +0000
commitdb74cd548483c2ea71d71022b0e9a01da7e1944b (patch)
tree3ccd9a2f3187f32a4854df6fd002d506db7be02b /dev-python/pyconstruct
parentBump (diff)
downloadgentoo-2-db74cd548483c2ea71d71022b0e9a01da7e1944b.tar.gz
gentoo-2-db74cd548483c2ea71d71022b0e9a01da7e1944b.tar.bz2
gentoo-2-db74cd548483c2ea71d71022b0e9a01da7e1944b.zip
Bump
(Portage version: 2.2.0_alpha176/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/pyconstruct')
-rw-r--r--dev-python/pyconstruct/ChangeLog7
-rw-r--r--dev-python/pyconstruct/pyconstruct-2.5.1.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/pyconstruct/ChangeLog b/dev-python/pyconstruct/ChangeLog
index 8d64d5b2c202..cfc30a4433fb 100644
--- a/dev-python/pyconstruct/ChangeLog
+++ b/dev-python/pyconstruct/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyconstruct
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/ChangeLog,v 1.7 2013/01/24 15:31:19 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/ChangeLog,v 1.8 2013/05/22 07:28:51 patrick Exp $
+
+*pyconstruct-2.5.1 (22 May 2013)
+
+ 22 May 2013; Patrick Lauer <patrick@gentoo.org> +pyconstruct-2.5.1.ebuild:
+ Bump
*pyconstruct-2.5.0-r1 (24 Jan 2013)
diff --git a/dev-python/pyconstruct/pyconstruct-2.5.1.ebuild b/dev-python/pyconstruct/pyconstruct-2.5.1.ebuild
new file mode 100644
index 000000000000..c978538802d2
--- /dev/null
+++ b/dev-python/pyconstruct/pyconstruct-2.5.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/pyconstruct-2.5.1.ebuild,v 1.1 2013/05/22 07:28:51 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit distutils eutils
+
+MY_PN="construct"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A powerful declarative parser for binary data"
+HOMEPAGE="http://construct.wikispaces.com/ http://pypi.python.org/pypi/construct"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools
+ dev-python/six"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="construct"