summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-01-17 21:37:02 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-01-17 21:37:02 +0000
commit9b59dc68f023b3bfe3ca48621f87fa4f910e9677 (patch)
treeabc8ba20dbbe8fa96f6e642f168b80b4ad2498f2 /dev-python/pyclimate
parentStable 2.6.25-r12 on amd64/x86 (diff)
downloadgentoo-2-9b59dc68f023b3bfe3ca48621f87fa4f910e9677.tar.gz
gentoo-2-9b59dc68f023b3bfe3ca48621f87fa4f910e9677.tar.bz2
gentoo-2-9b59dc68f023b3bfe3ca48621f87fa4f910e9677.zip
Bump to 1.2.2. Fixes #255246. Modified ebuild by Juan Aguado <juantxorena@gmail.com>
(Portage version: 2.2_rc22/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'dev-python/pyclimate')
-rw-r--r--dev-python/pyclimate/ChangeLog10
-rw-r--r--dev-python/pyclimate/pyclimate-1.2.2.ebuild54
2 files changed, 62 insertions, 2 deletions
diff --git a/dev-python/pyclimate/ChangeLog b/dev-python/pyclimate/ChangeLog
index 97b86330c90c..0506a5a477ea 100644
--- a/dev-python/pyclimate/ChangeLog
+++ b/dev-python/pyclimate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyclimate
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyclimate/ChangeLog,v 1.11 2007/03/05 02:49:35 genone Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyclimate/ChangeLog,v 1.12 2009/01/17 21:37:02 patrick Exp $
+
+*pyclimate-1.2.2 (17 Jan 2009)
+
+ 17 Jan 2009; Patrick Lauer <patrick@gentoo.org> +pyclimate-1.2.2.ebuild:
+ Bump to 1.2.2. Fixes #255246. Modified ebuild by Juan Aguado
+ <juantxorena@gmail.com>
05 Mar 2007; Marius Mauch <genone@gentoo.org> pyclimate-1.2.1-r1.ebuild:
Replacing einfo with elog
diff --git a/dev-python/pyclimate/pyclimate-1.2.2.ebuild b/dev-python/pyclimate/pyclimate-1.2.2.ebuild
new file mode 100644
index 000000000000..f393e5d05185
--- /dev/null
+++ b/dev-python/pyclimate/pyclimate-1.2.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyclimate/pyclimate-1.2.2.ebuild,v 1.1 2009/01/17 21:37:02 patrick Exp $
+
+inherit eutils distutils
+
+MY_P="${P/pyclimate/PyClimate}"
+S="${WORKDIR}/${MY_P}"
+
+IUSE=""
+DESCRIPTION="Climate Data Analysis Module for Python"
+SRC_URI="http://fisica.ehu.es/jsaenz/pyclimate_files/${MY_P}.tar.gz"
+HOMEPAGE="http://www.pyclimate.org/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~alpha ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND="virtual/python
+ dev-python/numpy
+ >=dev-python/scientificpython-2.8
+ >=sci-libs/netcdf-3.0"
+
+src_install() {
+
+ distutils_src_install
+
+ dodir /usr/share/doc/${PF}/doc
+ insinto /usr/share/doc/${PF}/doc
+ doins doc/*
+ doins doc/dcdflib_doc/dcdflib*
+
+ dodir /usr/share/${PF}/examples
+ insinto /usr/share/${PF}/examples
+ doins examples/*
+
+ dodir /usr/share/${PF}/test
+ insinto /usr/share/${PF}/test
+ doins test/*
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/pyclimate
+ elog
+ elog "Try the test script in /usr/share/${PF}/test."
+ elog "See the examples in /usr/share/${PF}/examples."
+ elog "Read the doc in /usr/share/doc/${PF}."
+ elog
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}