summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-04-04 02:41:02 +0000
committerTim Harder <radhermit@gentoo.org>2015-04-04 02:41:02 +0000
commit15b15a3209c014184fe646b3715b8529290ab999 (patch)
treefa90747d58de818c06dc942d47a4ef7bf0d4531b /dev-python/pychroot
parentBump filestore to 0.6.0.6 (diff)
downloadgentoo-2-15b15a3209c014184fe646b3715b8529290ab999.tar.gz
gentoo-2-15b15a3209c014184fe646b3715b8529290ab999.tar.bz2
gentoo-2-15b15a3209c014184fe646b3715b8529290ab999.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 4F064CA3)
Diffstat (limited to 'dev-python/pychroot')
-rw-r--r--dev-python/pychroot/ChangeLog8
-rw-r--r--dev-python/pychroot/pychroot-0.9.9.ebuild34
-rw-r--r--dev-python/pychroot/pychroot-9999.ebuild4
3 files changed, 43 insertions, 3 deletions
diff --git a/dev-python/pychroot/ChangeLog b/dev-python/pychroot/ChangeLog
index 2b4ee842b80e..179e8fdf5b75 100644
--- a/dev-python/pychroot/ChangeLog
+++ b/dev-python/pychroot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pychroot
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pychroot/ChangeLog,v 1.3 2015/03/25 23:20:35 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pychroot/ChangeLog,v 1.4 2015/04/04 02:41:02 radhermit Exp $
+
+*pychroot-0.9.9 (04 Apr 2015)
+
+ 04 Apr 2015; Tim Harder <radhermit@gentoo.org> +pychroot-0.9.9.ebuild,
+ pychroot-9999.ebuild:
+ Version bump.
*pychroot-0.9.8 (25 Mar 2015)
diff --git a/dev-python/pychroot/pychroot-0.9.9.ebuild b/dev-python/pychroot/pychroot-0.9.9.ebuild
new file mode 100644
index 000000000000..b13e3504ca1d
--- /dev/null
+++ b/dev-python/pychroot/pychroot-0.9.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pychroot/pychroot-0.9.9.ebuild,v 1.1 2015/04/04 02:41:02 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pychroot.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a python library that simplifies chroot handling"
+HOMEPAGE="https://github.com/pkgcore/pychroot"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=dev-python/snakeoil-0.6.2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/pychroot/pychroot-9999.ebuild b/dev-python/pychroot/pychroot-9999.ebuild
index cb3f7f3a5aa8..39e391766789 100644
--- a/dev-python/pychroot/pychroot-9999.ebuild
+++ b/dev-python/pychroot/pychroot-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pychroot/pychroot-9999.ebuild,v 1.2 2015/03/25 04:32:50 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pychroot/pychroot-9999.ebuild,v 1.3 2015/04/04 02:41:02 radhermit Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
@@ -21,7 +21,7 @@ LICENSE="BSD"
SLOT="0"
IUSE="test"
-RDEPEND=">=dev-python/snakeoil-0.6.1[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/snakeoil-0.6.2[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (