summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-03 00:20:11 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-03 00:20:11 +0000
commitd968b6be0aa8e97ab35e3c147d00d2a39b01f101 (patch)
tree5bfb12313265ae58c1584440ba9aa3bef2cb0105 /dev-python/pycairo
parentAdd PYTHON_REQ_USE as necessary for waf. (diff)
downloadgentoo-2-d968b6be0aa8e97ab35e3c147d00d2a39b01f101.tar.gz
gentoo-2-d968b6be0aa8e97ab35e3c147d00d2a39b01f101.tar.bz2
gentoo-2-d968b6be0aa8e97ab35e3c147d00d2a39b01f101.zip
Drop old.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/pycairo')
-rw-r--r--dev-python/pycairo/ChangeLog6
-rw-r--r--dev-python/pycairo/pycairo-1.10.0-r2.ebuild101
-rw-r--r--dev-python/pycairo/pycairo-1.10.0-r3.ebuild129
-rw-r--r--dev-python/pycairo/pycairo-1.8.10.ebuild77
4 files changed, 5 insertions, 308 deletions
diff --git a/dev-python/pycairo/ChangeLog b/dev-python/pycairo/ChangeLog
index 2be8815e9b99..8e3e219fc65b 100644
--- a/dev-python/pycairo/ChangeLog
+++ b/dev-python/pycairo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pycairo
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.146 2015/01/03 00:17:47 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.147 2015/01/03 00:20:11 mgorny Exp $
+
+ 03 Jan 2015; Michał Górny <mgorny@gentoo.org> -pycairo-1.10.0-r2.ebuild,
+ -pycairo-1.10.0-r3.ebuild, -pycairo-1.8.10.ebuild:
+ Drop old.
03 Jan 2015; Michał Górny <mgorny@gentoo.org> pycairo-1.10.0-r4.ebuild:
Add PYTHON_REQ_USE as necessary for waf.
diff --git a/dev-python/pycairo/pycairo-1.10.0-r2.ebuild b/dev-python/pycairo/pycairo-1.10.0-r2.ebuild
deleted file mode 100644
index c6855a62230d..000000000000
--- a/dev-python/pycairo/pycairo-1.10.0-r2.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.10.0-r2.ebuild,v 1.12 2013/01/05 07:22:37 floppym Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.6 3:3.1"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.5 3.0 *-jython *-pypy-*"
-
-inherit eutils python waf-utils
-
-PYCAIRO_PYTHON2_VERSION="${PV}"
-PYCAIRO_PYTHON3_VERSION="${PV}"
-
-DESCRIPTION="Python bindings for the cairo library"
-HOMEPAGE="http://cairographics.org/pycairo/ http://pypi.python.org/pypi/pycairo"
-SRC_URI="http://cairographics.org/releases/py2cairo-${PYCAIRO_PYTHON2_VERSION}.tar.bz2
- http://cairographics.org/releases/pycairo-${PYCAIRO_PYTHON3_VERSION}.tar.bz2"
-
-# LGPL-3 for pycairo 1.10.0.
-# || ( LGPL-2.1 MPL-1.1 ) for pycairo 1.8.10.
-LICENSE="LGPL-3 || ( LGPL-2.1 MPL-1.1 )"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc examples +svg test"
-
-RDEPEND=">=x11-libs/cairo-1.10.0[svg?]"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- test? ( dev-python/pytest )"
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-src_prepare() {
-
- pushd "${WORKDIR}/pycairo-${PYCAIRO_PYTHON3_VERSION}" > /dev/null
- rm -f src/config.h || die
- epatch "${FILESDIR}/${PN}-1.10.0-svg_check.patch"
- popd > /dev/null
-
- pushd "${WORKDIR}/py2cairo-${PYCAIRO_PYTHON2_VERSION}" > /dev/null
- rm -f src/config.h || die
- epatch "${FILESDIR}/py2cairo-1.10.0-svg_check.patch"
- popd > /dev/null
-
- preparation() {
- if [[ "${PYTHON_ABI}" == 3.* ]]; then
- cp -r "${WORKDIR}/pycairo-${PYCAIRO_PYTHON3_VERSION}" "${WORKDIR}/${P}-${PYTHON_ABI}"
- else
- cp -r "${WORKDIR}/py2cairo-${PYCAIRO_PYTHON2_VERSION}" "${WORKDIR}/${P}-${PYTHON_ABI}"
- fi
- }
- python_execute_function preparation
-}
-
-src_configure() {
- if ! use svg; then
- export PYCAIRO_DISABLE_SVG="1"
- fi
-
- python_execute_function -s waf-utils_src_configure --nopyc --nopyo
-}
-
-src_compile() {
- python_execute_function -s waf-utils_src_compile
-}
-
-src_test() {
- test_installation() {
- ./waf install --destdir="${T}/tests/${PYTHON_ABI}"
- }
- python_execute_function -q -s test_installation
-
- python_execute_py.test -P '${T}/tests/${PYTHON_ABI}${EPREFIX}$(python_get_sitedir)' -s
-}
-
-src_install() {
- python_execute_function -s waf-utils_src_install
-
- dodoc AUTHORS NEWS README || die "dodoc failed"
-
- if use doc; then
- pushd doc/_build/html > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/* || die "Installation of examples failed"
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize cairo
-}
-
-pkg_postrm() {
- python_mod_cleanup cairo
-}
diff --git a/dev-python/pycairo/pycairo-1.10.0-r3.ebuild b/dev-python/pycairo/pycairo-1.10.0-r3.ebuild
deleted file mode 100644
index 1f9ee0072d86..000000000000
--- a/dev-python/pycairo/pycairo-1.10.0-r3.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.10.0-r3.ebuild,v 1.14 2013/01/06 09:29:29 ago Exp $
-
-EAPI="4"
-PYTHON_DEPEND="2:2.6 3:3.1"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.5 3.0 *-jython *-pypy-*"
-
-inherit eutils python waf-utils
-
-PYCAIRO_PYTHON2_VERSION="${PV}"
-PYCAIRO_PYTHON3_VERSION="${PV}"
-
-DESCRIPTION="Python bindings for the cairo library"
-HOMEPAGE="http://cairographics.org/pycairo/ http://pypi.python.org/pypi/pycairo"
-SRC_URI="http://cairographics.org/releases/py2cairo-${PYCAIRO_PYTHON2_VERSION}.tar.bz2
- http://cairographics.org/releases/pycairo-${PYCAIRO_PYTHON3_VERSION}.tar.bz2"
-
-# LGPL-3 for pycairo 1.10.0.
-# || ( LGPL-2.1 MPL-1.1 ) for pycairo 1.8.10.
-LICENSE="LGPL-3 || ( LGPL-2.1 MPL-1.1 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples +svg test xcb"
-
-RDEPEND=">=x11-libs/cairo-1.10.0[svg?,xcb?]
- xcb? ( x11-libs/xpyb )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- test? ( dev-python/pytest )"
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-src_prepare() {
-
- pushd "${WORKDIR}/pycairo-${PYCAIRO_PYTHON3_VERSION}" > /dev/null
- rm -f src/config.h || die
- epatch "${FILESDIR}/${PN}-1.10.0-svg_check.patch"
- epatch "${FILESDIR}/${PN}-1.10.0-xpyb.patch"
- epatch "${FILESDIR}"/py2cairo-1.10.0-ppc-darwin.patch
- popd > /dev/null
-
- pushd "${WORKDIR}/py2cairo-${PYCAIRO_PYTHON2_VERSION}" > /dev/null
- rm -f src/config.h || die
- epatch "${FILESDIR}/py2cairo-1.10.0-svg_check.patch"
- epatch "${FILESDIR}/py2cairo-1.10.0-xpyb.patch"
- epatch "${FILESDIR}"/py2cairo-1.10.0-ppc-darwin.patch
- popd > /dev/null
-
- preparation() {
- if [[ "${PYTHON_ABI}" == 3.* ]]; then
- cp -r "${WORKDIR}/pycairo-${PYCAIRO_PYTHON3_VERSION}" "${WORKDIR}/${P}-${PYTHON_ABI}"
- else
- cp -r "${WORKDIR}/py2cairo-${PYCAIRO_PYTHON2_VERSION}" "${WORKDIR}/${P}-${PYTHON_ABI}"
- fi
- }
- python_execute_function preparation
-}
-
-src_configure() {
- if ! use svg; then
- export PYCAIRO_DISABLE_SVG=1
- fi
-
- if ! use xcb; then
- export PYCAIRO_DISABLE_XPYB=1
- fi
-
- # Added by grobian:
- # If WAF_BINARY is an absolute path, the configure is different and fails to
- # find Python.h due to a compiler misconfiguration. If WAF_BINARY is just
- # ./waf or python waf, it works fine. Hooray for reinvented buildsystems
-
- # floppym:
- # pycairo and py2cairo bundle different versions of waf (bug 447856)
- WAF_BINARY="./waf"
- python_execute_function -s waf-utils_src_configure --nopyc --nopyo
-}
-
-src_compile() {
- python_execute_function -s waf-utils_src_compile
-}
-
-src_test() {
- test_installation() {
- ./waf install --destdir="${T}/tests/${PYTHON_ABI}"
- }
- python_execute_function -q -s test_installation
-
- python_execute_py.test -P '${T}/tests/${PYTHON_ABI}${EPREFIX}$(python_get_sitedir)' -s
-}
-
-src_install() {
- python_execute_function -s waf-utils_src_install
-
- dodoc AUTHORS NEWS README || die "dodoc failed"
-
- if use doc; then
- pushd doc/_build/html > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/* || die "Installation of examples failed"
- fi
-
- if [[ ${CHOST} == *-darwin* ]] ; then
- # fix install_names; next to waf producing dylibs (not bundles) and
- # calling them .bundle, it also has no idea what it should do to create
- # proper ones (dylibs)
- fix_darwin_install_names() {
- local x=$(python_get_sitedir)/cairo/_cairo.bundle
- install_name_tool -id "${EPREFIX}${x}" "${ED}${x}"
- }
- python_execute_function fix_darwin_install_names
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize cairo
-}
-
-pkg_postrm() {
- python_mod_cleanup cairo
-}
diff --git a/dev-python/pycairo/pycairo-1.8.10.ebuild b/dev-python/pycairo/pycairo-1.8.10.ebuild
deleted file mode 100644
index 8c52c65e558f..000000000000
--- a/dev-python/pycairo/pycairo-1.8.10.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.8.10.ebuild,v 1.16 2012/06/02 11:59:24 marienz Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-pypy-*"
-DISTUTILS_SRC_TEST="py.test"
-
-inherit eutils distutils flag-o-matic multilib
-
-DESCRIPTION="Python wrapper for cairo vector graphics library"
-HOMEPAGE="http://cairographics.org/pycairo/ http://pypi.python.org/pypi/pycairo"
-SRC_URI="http://cairographics.org/releases/py2cairo-${PV}.tar.gz"
-
-LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc examples svg"
-
-RDEPEND=">=x11-libs/cairo-1.8.10[svg?]"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( >=dev-python/sphinx-0.6 )"
-
-DOCS="AUTHORS NEWS README"
-PYTHON_MODNAME="cairo"
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${P}-pkgconfig_dir.patch"
- epatch "${FILESDIR}/${PN}-1.8.8-svg_check.patch"
-}
-
-src_configure() {
- if ! use svg; then
- export PYCAIRO_DISABLE_SVG="1"
- fi
-}
-
-distutils_src_compile_post_hook() {
- cp src/__init__.py "$(ls -d build-${PYTHON_ABI}/lib.*/cairo)" || die "Copying of src/__init__.py failed"
-}
-
-src_compile() {
- append-flags -fno-strict-aliasing
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- pushd doc > /dev/null
- sphinx-build -b html -d .build/doctrees . .build/html || die "Generation of documentation failed"
- popd > /dev/null
- fi
-}
-
-src_test() {
- python_execute_py.test -P '$(ls -d build-${PYTHON_ABI}/lib.*):../../$(ls -d build-${PYTHON_ABI}/lib.*)'
-}
-
-src_install() {
- PKGCONFIG_DIR="${EPREFIX}/usr/$(get_libdir)/pkgconfig" distutils_src_install
-
- if use doc; then
- dohtml -r doc/.build/html/ || die "dohtml -r doc/.build/html/ failed"
- fi
-
- if use examples; then
- # Delete files created by tests.
- find examples/cairo_snippets/snippets -maxdepth 1 -name "*.png" | xargs rm -f
-
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/*
- rm "${ED}"usr/share/doc/${PF}/examples/Makefile*
- fi
-}