summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-04-02 05:26:04 +0000
committerIan Delaney <idella4@gentoo.org>2014-04-02 05:26:04 +0000
commit757c4b933931b4ef648e08eeb7e52c1e3ce2fac9 (patch)
treea3df9ecd0b04eaa5eff1a9b6a634b44bbb83012f /dev-python/pyacoustid
parentAdd perl dep #504708 (diff)
downloadgentoo-2-757c4b933931b4ef648e08eeb7e52c1e3ce2fac9.tar.gz
gentoo-2-757c4b933931b4ef648e08eeb7e52c1e3ce2fac9.tar.bz2
gentoo-2-757c4b933931b4ef648e08eeb7e52c1e3ce2fac9.zip
revbump; add IUSE examples, install_all phase, fixes Bug #493326
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pyacoustid')
-rw-r--r--dev-python/pyacoustid/ChangeLog7
-rw-r--r--dev-python/pyacoustid/pyacoustid-1.0.0-r1.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-python/pyacoustid/ChangeLog b/dev-python/pyacoustid/ChangeLog
index 1918c2215d91..9287328b04ce 100644
--- a/dev-python/pyacoustid/ChangeLog
+++ b/dev-python/pyacoustid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyacoustid
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyacoustid/ChangeLog,v 1.6 2014/03/22 18:55:30 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyacoustid/ChangeLog,v 1.7 2014/04/02 05:26:04 idella4 Exp $
+
+*pyacoustid-1.0.0-r1 (02 Apr 2014)
+
+ 02 Apr 2014; Ian Delaney <idella4@gentoo.org> +pyacoustid-1.0.0-r1.ebuild:
+ revbump; add IUSE examples, install_all phase, fixes Bug #493326
22 Mar 2014; Michael Palimaka <kensington@gentoo.org> -pyacoustid-0.7.ebuild:
Remove old.
diff --git a/dev-python/pyacoustid/pyacoustid-1.0.0-r1.ebuild b/dev-python/pyacoustid/pyacoustid-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..6c69a65558cf
--- /dev/null
+++ b/dev-python/pyacoustid/pyacoustid-1.0.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyacoustid/pyacoustid-1.0.0-r1.ebuild,v 1.1 2014/04/02 05:26:04 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for Chromaprint acoustic fingerprinting and the Acoustid API"
+HOMEPAGE="http://pypi.python.org/pypi/pyacoustid"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="media-libs/chromaprint
+ dev-python/audioread[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ use examples && local EXAMPLES=( ./aidmatch.py)
+ distutils-r1_python_install_all
+}