summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-01-04 21:49:17 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-01-04 21:49:17 +0000
commitd991a4d5ded958969db9c7b6480ab3563d3c25eb (patch)
tree4e8ba3b664a8227d3436ac02589b57bc58b2f0c6 /dev-python/polygon/polygon-2.0.4.ebuild
parentVersion bump #397695. (diff)
downloadgentoo-2-d991a4d5ded958969db9c7b6480ab3563d3c25eb.tar.gz
gentoo-2-d991a4d5ded958969db9c7b6480ab3563d3c25eb.tar.bz2
gentoo-2-d991a4d5ded958969db9c7b6480ab3563d3c25eb.zip
Initial import
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/polygon/polygon-2.0.4.ebuild')
-rw-r--r--dev-python/polygon/polygon-2.0.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/polygon/polygon-2.0.4.ebuild b/dev-python/polygon/polygon-2.0.4.ebuild
new file mode 100644
index 000000000000..4dd99fd94097
--- /dev/null
+++ b/dev-python/polygon/polygon-2.0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/polygon/polygon-2.0.4.ebuild,v 1.1 2012/01/04 21:49:17 bicatali Exp $
+
+EAPI=3
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Python package to handle polygonal shapes in 2D"
+HOMEPAGE="http://www.j-raedler.de/projects/polygon/"
+SRC_URI="https://github.com/downloads/jraedler/Polygon2/Polygon-${PV}.zip"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/Polygon-${PV}"
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(dir -d build-${PYTHON_ABI}/lib*)" "$(PYTHON)" test/Test.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ dodoc HISTORY doc/Polygon.txt
+}