summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-11 15:57:19 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-11 15:57:19 +0000
commit2d501aebb579d60abd9c7db34c8eab35a45a370d (patch)
treeb24a2c6df47e9bf9455f65f986ebfbd4c14ca42b /dev-python/oct2py
parentStable for s390, wrt bug #456080 (diff)
downloadgentoo-2-2d501aebb579d60abd9c7db34c8eab35a45a370d.tar.gz
gentoo-2-2d501aebb579d60abd9c7db34c8eab35a45a370d.tar.bz2
gentoo-2-2d501aebb579d60abd9c7db34c8eab35a45a370d.zip
Clean up a bit. Enable py2.6 as needed by ipython. Disable Python 3 as not supported by scipy.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/oct2py')
-rw-r--r--dev-python/oct2py/ChangeLog6
-rw-r--r--dev-python/oct2py/oct2py-0.4.0.ebuild20
2 files changed, 16 insertions, 10 deletions
diff --git a/dev-python/oct2py/ChangeLog b/dev-python/oct2py/ChangeLog
index 1fe9f82e0f59..55c5d0d66e50 100644
--- a/dev-python/oct2py/ChangeLog
+++ b/dev-python/oct2py/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/oct2py
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oct2py/ChangeLog,v 1.7 2013/01/22 06:55:35 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oct2py/ChangeLog,v 1.8 2013/02/11 15:57:19 mgorny Exp $
+
+ 11 Feb 2013; Michał Górny <mgorny@gentoo.org> oct2py-0.4.0.ebuild:
+ Clean up a bit. Enable py2.6 as needed by ipython. Disable Python 3 as not
+ supported by scipy.
*oct2py-0.4.0 (22 Jan 2013)
diff --git a/dev-python/oct2py/oct2py-0.4.0.ebuild b/dev-python/oct2py/oct2py-0.4.0.ebuild
index d07c637d416d..46393433e142 100644
--- a/dev-python/oct2py/oct2py-0.4.0.ebuild
+++ b/dev-python/oct2py/oct2py-0.4.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oct2py/oct2py-0.4.0.ebuild,v 1.1 2013/01/22 06:55:35 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oct2py/oct2py-0.4.0.ebuild,v 1.2 2013/02/11 15:57:19 mgorny Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_2} )
+PYTHON_COMPAT=( python{2_6,2_7} )
inherit distutils-r1
@@ -17,10 +17,10 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples"
-RDEPEND="sci-libs/scipy
+RDEPEND="sci-libs/scipy[${PYTHON_USEDEP}]
sci-mathematics/octave"
DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )"
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
python_compile_all() {
if use doc; then
@@ -29,14 +29,16 @@ python_compile_all() {
}
python_test() {
- nosetests || die
+ nosetests || die "Tests fail with ${EPYTHON}"
}
python_install_all() {
- use doc && dohtml -r html/
+ use doc && local HTML_DOCS=( html/. )
+ distutils-r1_python_install_all
+
if use examples; then
- docompress -x /usr/share/doc/${PF}/example
- insinto /usr/share/doc/${PF}/
- doins -r example/
+ docompress -x /usr/share/doc/${PF}/examples
+ docinto examples
+ doins -r example/.
fi
}