summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-10-20 18:24:00 +0000
committerJustin Lecher <jlec@gentoo.org>2013-10-20 18:24:00 +0000
commit27f5a19824d7a17ea40e435eb681f6eb10ec7467 (patch)
tree95aef5d156aadf20c3c1452a6b4e7a14eb09afde /dev-python/oct2py
parentMove dev-python/audioread to maintainer-needed (diff)
downloadgentoo-2-27f5a19824d7a17ea40e435eb681f6eb10ec7467.tar.gz
gentoo-2-27f5a19824d7a17ea40e435eb681f6eb10ec7467.tar.bz2
gentoo-2-27f5a19824d7a17ea40e435eb681f6eb10ec7467.zip
dev-python/oct2py: Add missing test dep; Version Bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python/oct2py')
-rw-r--r--dev-python/oct2py/ChangeLog8
-rw-r--r--dev-python/oct2py/oct2py-0.4.0-r1.ebuild7
-rw-r--r--dev-python/oct2py/oct2py-1.0.0.ebuild49
3 files changed, 60 insertions, 4 deletions
diff --git a/dev-python/oct2py/ChangeLog b/dev-python/oct2py/ChangeLog
index 754ed6834a4c..633a93ae82d3 100644
--- a/dev-python/oct2py/ChangeLog
+++ b/dev-python/oct2py/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/oct2py
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oct2py/ChangeLog,v 1.9 2013/03/01 12:32:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oct2py/ChangeLog,v 1.10 2013/10/20 18:24:00 jlec Exp $
+
+*oct2py-1.0.0 (20 Oct 2013)
+
+ 20 Oct 2013; Justin Lecher <jlec@gentoo.org> oct2py-0.4.0-r1.ebuild,
+ +oct2py-1.0.0.ebuild:
+ Add missing test dep; Version Bump
*oct2py-0.4.0-r1 (01 Mar 2013)
diff --git a/dev-python/oct2py/oct2py-0.4.0-r1.ebuild b/dev-python/oct2py/oct2py-0.4.0-r1.ebuild
index be943680af7f..3e8e3378b9ab 100644
--- a/dev-python/oct2py/oct2py-0.4.0-r1.ebuild
+++ b/dev-python/oct2py/oct2py-0.4.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oct2py/oct2py-0.4.0-r1.ebuild,v 1.1 2013/03/01 12:32:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oct2py/oct2py-0.4.0-r1.ebuild,v 1.2 2013/10/20 18:24:00 jlec Exp $
EAPI=5
@@ -15,13 +15,14 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples"
+IUSE="doc examples test"
RDEPEND="
sci-libs/scipy[${PYTHON_USEDEP}]
sci-mathematics/octave"
DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
python_compile_all() {
if use doc; then
diff --git a/dev-python/oct2py/oct2py-1.0.0.ebuild b/dev-python/oct2py/oct2py-1.0.0.ebuild
new file mode 100644
index 000000000000..dd54af67fc42
--- /dev/null
+++ b/dev-python/oct2py/oct2py-1.0.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oct2py/oct2py-1.0.0.ebuild,v 1.1 2013/10/20 18:24:00 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python to GNU Octave bridge"
+HOMEPAGE="http://pypi.python.org/pypi/oct2py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-mathematics/octave"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ )"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build doc html || die
+ fi
+}
+
+python_test() {
+ nosetests oct2py --with-doctest || die "Tests fail with ${EPYTHON}"
+ iptest -v IPython.extensions.tests.test_octavemagic || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( html/. )
+ distutils-r1_python_install_all
+
+ if use examples; then
+ insinto /usr/share/${PF}/
+ doins -r example
+ fi
+}