summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-04-08 02:50:20 +0000
committerIan Delaney <idella4@gentoo.org>2014-04-08 02:50:20 +0000
commit7a721026c45499eae2d4502453c81ef70e224fe9 (patch)
tree2479e84586ae50ebf271a507d3d9043c0ae77f1d /dev-python/nose-cover3
parentnew release from upstream and live fixes (diff)
downloadgentoo-2-7a721026c45499eae2d4502453c81ef70e224fe9.tar.gz
gentoo-2-7a721026c45499eae2d4502453c81ef70e224fe9.tar.bz2
gentoo-2-7a721026c45499eae2d4502453c81ef70e224fe9.zip
Add py3.4 support, rm old
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/nose-cover3')
-rw-r--r--dev-python/nose-cover3/ChangeLog6
-rw-r--r--dev-python/nose-cover3/nose-cover3-0.1.0-r1.ebuild4
-rw-r--r--dev-python/nose-cover3/nose-cover3-0.1.0.ebuild27
3 files changed, 7 insertions, 30 deletions
diff --git a/dev-python/nose-cover3/ChangeLog b/dev-python/nose-cover3/ChangeLog
index c2a03133ec09..fc6311e057d0 100644
--- a/dev-python/nose-cover3/ChangeLog
+++ b/dev-python/nose-cover3/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/nose-cover3
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose-cover3/ChangeLog,v 1.6 2014/03/31 21:19:55 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose-cover3/ChangeLog,v 1.7 2014/04/08 02:50:20 idella4 Exp $
+
+ 08 Apr 2014; Ian Delaney <idella4@gentoo.org> -nose-cover3-0.1.0.ebuild,
+ nose-cover3-0.1.0-r1.ebuild:
+ Add py3.4 support, rm old
31 Mar 2014; Michał Górny <mgorny@gentoo.org> nose-cover3-0.1.0-r1.ebuild:
Add support for the new PyPy slotting.
diff --git a/dev-python/nose-cover3/nose-cover3-0.1.0-r1.ebuild b/dev-python/nose-cover3/nose-cover3-0.1.0-r1.ebuild
index 256ced595f5f..c8a7e2366ea5 100644
--- a/dev-python/nose-cover3/nose-cover3-0.1.0-r1.ebuild
+++ b/dev-python/nose-cover3/nose-cover3-0.1.0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose-cover3/nose-cover3-0.1.0-r1.ebuild,v 1.3 2014/03/31 21:19:55 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose-cover3/nose-cover3-0.1.0-r1.ebuild,v 1.4 2014/04/08 02:50:20 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy pypy2_0 )
inherit distutils-r1
diff --git a/dev-python/nose-cover3/nose-cover3-0.1.0.ebuild b/dev-python/nose-cover3/nose-cover3-0.1.0.ebuild
deleted file mode 100644
index afcfff96b305..000000000000
--- a/dev-python/nose-cover3/nose-cover3-0.1.0.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose-cover3/nose-cover3-0.1.0.ebuild,v 1.2 2012/06/12 11:37:53 iksaif Exp $
-
-EAPI="4"
-
-PYTHON_DEPEND="2 3"
-RESTRICT_PYTHON_ABIS="2.4"
-SUPPORT_PYTHON_ABIS="1"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils
-
-DESCRIPTION="Coverage 3.x support for Nose"
-HOMEPAGE="https://github.com/ask/nosecover3 http://pypi.python.org/pypi/nose-cover3"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/nose"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-PYTHON_MODNAME="nosecover3"