summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-04-22 14:12:38 +0000
committerIan Delaney <idella4@gentoo.org>2013-04-22 14:12:38 +0000
commit1efd2a53c7c2a22379d78179f79d8e2f35b6bfe9 (patch)
treeaf25cd1d6f18df64755301088012261240ed6ac2 /dev-python/nose-cover3
parentFast stable 0.0.13 on amd64 x86 and ppc due to problems in the former version... (diff)
downloadgentoo-2-1efd2a53c7c2a22379d78179f79d8e2f35b6bfe9.tar.gz
gentoo-2-1efd2a53c7c2a22379d78179f79d8e2f35b6bfe9.tar.bz2
gentoo-2-1efd2a53c7c2a22379d78179f79d8e2f35b6bfe9.zip
migration -> distutils-r1
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/nose-cover3')
-rw-r--r--dev-python/nose-cover3/ChangeLog10
-rw-r--r--dev-python/nose-cover3/nose-cover3-0.1.0-r1.ebuild22
2 files changed, 29 insertions, 3 deletions
diff --git a/dev-python/nose-cover3/ChangeLog b/dev-python/nose-cover3/ChangeLog
index a68e707aa88c..a8a0ac6d992b 100644
--- a/dev-python/nose-cover3/ChangeLog
+++ b/dev-python/nose-cover3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/nose-cover3
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose-cover3/ChangeLog,v 1.2 2012/06/12 11:37:53 iksaif Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose-cover3/ChangeLog,v 1.3 2013/04/22 14:12:38 idella4 Exp $
+
+*nose-cover3-0.1.0-r1 (22 Apr 2013)
+
+ 22 Apr 2013; Ian Delaney <idella4@gentoo.org> +nose-cover3-0.1.0-r1.ebuild:
+ migration -> distutils-r1
12 Jun 2012; Corentin Chary <iksaif@gentoo.org> nose-cover3-0.1.0.ebuild:
Fix HOMEPAGE.
@@ -10,4 +15,3 @@
30 May 2012; Corentin Chary <iksaif@gentoo.org> +metadata.xml,
+nose-cover3-0.1.0.ebuild:
New ebuild for nose-cover3.
-
diff --git a/dev-python/nose-cover3/nose-cover3-0.1.0-r1.ebuild b/dev-python/nose-cover3/nose-cover3-0.1.0-r1.ebuild
new file mode 100644
index 000000000000..04221b02eb5b
--- /dev/null
+++ b/dev-python/nose-cover3/nose-cover3-0.1.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose-cover3/nose-cover3-0.1.0-r1.ebuild,v 1.1 2013/04/22 14:12:38 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Coverage 3.x support for Nose"
+HOMEPAGE="https://github.com/ask/nosecover3 http://pypi.python.org/pypi/nose-cover3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/nose[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"