summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-20 12:57:09 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-20 12:57:09 +0000
commit4ffd0c907b1c07e5550411d3857d2519fc6c6e68 (patch)
tree2179a5be8ae7b33e324ba315f1d6aee40c4ba004 /dev-python/matplotlib
parentVersion bump upstream stable. Bump alpha to new rc. Remove older unstables. (diff)
downloadgentoo-2-4ffd0c907b1c07e5550411d3857d2519fc6c6e68.tar.gz
gentoo-2-4ffd0c907b1c07e5550411d3857d2519fc6c6e68.tar.bz2
gentoo-2-4ffd0c907b1c07e5550411d3857d2519fc6c6e68.zip
Drop old; add qt5 support, bug #530492; fix slot usages
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/ChangeLog7
-rw-r--r--dev-python/matplotlib/matplotlib-1.1.1.ebuild161
-rw-r--r--dev-python/matplotlib/matplotlib-1.3.0-r1.ebuild204
-rw-r--r--dev-python/matplotlib/matplotlib-1.4.0.ebuild247
-rw-r--r--dev-python/matplotlib/matplotlib-1.4.2.ebuild8
-rw-r--r--dev-python/matplotlib/matplotlib-1.4.3.ebuild21
-rw-r--r--dev-python/matplotlib/matplotlib-9999.ebuild63
7 files changed, 63 insertions, 648 deletions
diff --git a/dev-python/matplotlib/ChangeLog b/dev-python/matplotlib/ChangeLog
index aec9ab09d7e1..02674eafcad0 100644
--- a/dev-python/matplotlib/ChangeLog
+++ b/dev-python/matplotlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/matplotlib
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.186 2015/03/09 00:03:04 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.187 2015/03/20 12:57:09 jlec Exp $
+
+ 20 Mar 2015; Justin Lecher <jlec@gentoo.org> -matplotlib-1.1.1.ebuild,
+ -matplotlib-1.3.0-r1.ebuild, -matplotlib-1.4.0.ebuild,
+ matplotlib-1.4.2.ebuild, matplotlib-1.4.3.ebuild, matplotlib-9999.ebuild:
+ Drop old; add qt5 support, bug #530492; fix slot usages
09 Mar 2015; Pacho Ramos <pacho@gentoo.org> matplotlib-1.4.2.ebuild:
x86 stable, bug 540290
diff --git a/dev-python/matplotlib/matplotlib-1.1.1.ebuild b/dev-python/matplotlib/matplotlib-1.1.1.ebuild
deleted file mode 100644
index e870facedf6d..000000000000
--- a/dev-python/matplotlib/matplotlib-1.1.1.ebuild
+++ /dev/null
@@ -1,161 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.1.1.ebuild,v 1.10 2013/09/12 22:29:33 mgorny Exp $
-
-EAPI="3"
-
-PYTHON_DEPEND="2"
-PYTHON_USE_WITH="tk"
-PYTHON_USE_WITH_OPT="tk"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3* *-jython 2.7-pypy-*"
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-PYTHON_CXXFLAGS=("2.* + -fno-strict-aliasing")
-PYTHON_MODNAME="matplotlib mpl_toolkits pylab.py"
-
-WX_GTK_VER="2.8"
-
-inherit distutils eutils
-
-DESCRIPTION="Pure python plotting library with matlab like syntax"
-HOMEPAGE="http://matplotlib.sourceforge.net/ http://pypi.python.org/pypi/matplotlib"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-IUSE="cairo doc excel examples fltk gtk latex qt4 test tk wxwidgets"
-SLOT="0"
-KEYWORDS="amd64 ppc ~ppc64 x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-# Main license: matplotlib
-# Some modules: BSD
-# matplotlib/backends/qt4_editor: MIT
-# Fonts: BitstreamVera, OFL-1.1
-LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
-
-CDEPEND="dev-python/numpy
- dev-python/python-dateutil
- dev-python/pytz
- media-libs/freetype:2
- media-libs/libpng
- gtk? ( dev-python/pygtk )
- wxwidgets? ( dev-python/wxpython:2.8 )"
-
-# internal copy of pycxx highly patched
-# dev-python/pycxx
-
-DEPEND="${CDEPEND}
- virtual/pkgconfig
- doc? (
- app-text/dvipng
- virtual/python-imaging
- dev-python/ipython
- dev-python/xlwt
- dev-python/sphinx
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-fontsrecommended
- dev-texlive/texlive-latexrecommended
- media-gfx/graphviz[cairo]
- )
- test? ( dev-python/nose )"
-
-RDEPEND="${CDEPEND}
- dev-python/pyparsing
- cairo? ( dev-python/pycairo )
- excel? ( dev-python/xlwt )
- fltk? ( dev-python/pyfltk )
- latex? (
- virtual/latex-base
- app-text/ghostscript-gpl
- app-text/dvipng
- app-text/poppler[utils]
- dev-texlive/texlive-fontsrecommended
- )
- qt4? ( || ( dev-python/PyQt4[X] dev-python/pyside[X] ) )"
-
-use_setup() {
- local uword="${2:-${1}}"
- if use ${1}; then
- echo "${uword} = True"
- echo "${uword}agg = True"
- else
- echo "${uword} = False"
- echo "${uword}agg = False"
- fi
-}
-
-src_prepare() {
- # from upstream commit ca678a49f37411b1b0e72d7d0dfa88c124b0e34b
- epatch "${FILESDIR}"/${P}-ft-refcount.patch
-
- # create setup.cfg (see setup.cfg.template for any changes)
- cat > setup.cfg <<-EOF
- [provide_packages]
- pytz = False
- dateutil = False
- [gui_support]
- $(use_setup cairo)
- $(use_setup fltk)
- $(use_setup gtk)
- $(use_setup qt4)
- $(use_setup tk)
- $(use_setup wxwidgets wx)
- EOF
-
- # avoid checks needing a X display
- sed -i \
- -e "s/check_for_gtk()/$(use gtk && echo True || echo False)/" \
- -e "s/check_for_tk()/$(use tk && echo True || echo False)/" \
- setup.py || die "sed setup.py failed"
-
- # remove internal copies of pyparsing
- rm lib/matplotlib/pyparsing.py || die
- sed -i \
- -e 's/matplotlib.pyparsing/pyparsing/g' \
- lib/matplotlib/{mathtext,fontconfig_pattern}.py \
- || die "sed pyparsing failed"
- distutils_src_prepare
-}
-
-src_compile() {
- unset DISPLAY # bug #278524
- distutils_src_compile
- makedocs() {
- if use doc; then
- cd "${S}/doc"
- VARTEXFONTS="${T}"/fonts \
- PYTHONPATH=$(ls -d "${S}"/build-$(PYTHON -f --ABI)/lib*) \
- ./make.py --small all
- [[ -e build/latex/Matplotlib.pdf ]] || die "doc generation failed"
- fi
- }
- python_execute_function -f makedocs
-}
-
-src_test() {
- # if doc was enabled, all examples were built and tested
- use doc && return
- testing() {
- "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install \
- --home="${S}/test-${PYTHON_ABI}" --no-compile \
- || die "install test failed"
- pushd "${S}/test-${PYTHON_ABI}/"lib* > /dev/null
- PYTHONPATH=python \
- "$(PYTHON)" -c "import matplotlib as m; m.test(verbosity=2)" \
- 2>&1 | tee test.log
- grep -Eq "^(ERROR|FAIL):" test.log && return 1
- popd > /dev/null
- rm -r test-${PYTHON_ABI}
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- if use doc; then
- insinto /usr/share/doc/${PF}
- doins -r doc/build/latex/Matplotlib.pdf doc/build/html || die
- fi
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die
- fi
-}
diff --git a/dev-python/matplotlib/matplotlib-1.3.0-r1.ebuild b/dev-python/matplotlib/matplotlib-1.3.0-r1.ebuild
deleted file mode 100644
index fdf5f44d9f18..000000000000
--- a/dev-python/matplotlib/matplotlib-1.3.0-r1.ebuild
+++ /dev/null
@@ -1,204 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.3.0-r1.ebuild,v 1.1 2015/01/05 14:40:19 hasufell Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_2,3_3} )
-PYTHON_REQ_USE='tk?'
-
-inherit distutils-r1 eutils flag-o-matic
-
-DESCRIPTION="Pure python plotting library with matlab like syntax"
-HOMEPAGE="http://matplotlib.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-IUSE="cairo doc excel examples fltk gtk gtk3 latex qt4 test tk wxwidgets"
-SLOT="0"
-KEYWORDS="amd64 arm ~mips ~ppc ~ppc64 x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-# Main license: matplotlib
-# Some modules: BSD
-# matplotlib/backends/qt4_editor: MIT
-# Fonts: BitstreamVera, OFL-1.1
-LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
-
-# #456704 -- a lot of py2-only deps
-PY2_USEDEP=$(python_gen_usedep 'python2*')
-COMMON_DEPEND="
- <dev-python/numpy-1.9.0[${PYTHON_USEDEP}]
- dev-python/python-dateutil:0[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- media-fonts/stix-fonts
- media-libs/freetype:2
- media-libs/libpng:0
- gtk? ( x11-libs/gtk+:2
- dev-libs/glib
- x11-libs/gdk-pixbuf
- dev-python/pygtk[${PY2_USEDEP}] )
- wxwidgets? ( dev-python/wxpython[${PY2_USEDEP}] )"
-
-# internal copy of pycxx highly patched
-# dev-python/pycxx
-
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- doc? (
- app-text/dvipng
- virtual/python-imaging[${PYTHON_USEDEP}]
- dev-python/ipython
- dev-python/numpydoc[${PY2_USEDEP}]
- dev-python/xlwt[${PY2_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-fontsrecommended
- dev-texlive/texlive-latexrecommended
- media-gfx/graphviz[cairo]
- )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-RDEPEND="${COMMON_DEPEND}
- dev-python/pyparsing[${PYTHON_USEDEP}]
- cairo? ( dev-python/pycairo[${PYTHON_USEDEP}] )
- excel? ( dev-python/xlwt[${PY2_USEDEP}] )
- fltk? ( dev-python/pyfltk[${PY2_USEDEP}] )
- gtk3? ( dev-python/pygobject:3[${PYTHON_USEDEP}]
- x11-libs/gtk+:3[introspection] )
- latex? (
- virtual/latex-base
- app-text/ghostscript-gpl
- app-text/dvipng
- app-text/poppler[utils]
- dev-texlive/texlive-fontsrecommended
- )
- qt4? ( || ( dev-python/PyQt4[X,${PYTHON_USEDEP}] dev-python/pyside[X,${PYTHON_USEDEP}] ) )"
-
-PY2_FLAGS="|| ( $(python_gen_useflags python2*) )"
-REQUIRED_USE="doc? ( ${PY2_FLAGS} )
- excel? ( ${PY2_FLAGS} )
- fltk? ( ${PY2_FLAGS} )
- gtk? ( ${PY2_FLAGS} )
- wxwidgets? ( ${PY2_FLAGS} )"
-
-RESTRICT="mirror"
-
-# A few C++ source files are written to srcdir.
-# Other than that, the ebuild shall be fit for out-of-source build.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-use_setup() {
- local uword="${2:-${1}}"
- if use ${1}; then
- echo "${uword} = True"
- echo "${uword}agg = True"
- else
- echo "${uword} = False"
- echo "${uword}agg = False"
- fi
-}
-
-python_prepare_all() {
- sed -i -e 's/matplotlib.pyparsing_py[23]/pyparsing/g' \
- lib/matplotlib/{mathtext,fontconfig_pattern}.py \
- || die "sed pyparsing failed"
-
- local PATCHES=(
- # avoid checks needing a X display
- "${FILESDIR}"/${P}-setup_without_X11.patch
- )
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- append-flags -fno-strict-aliasing
-}
-
-python_configure() {
- mkdir -p "${BUILD_DIR}" || die
-
- # create setup.cfg (see setup.cfg.template for any changes).
-
- # common switches.
- cat > "${BUILD_DIR}"/setup.cfg <<-EOF
- [directories]
- basedirlist = ${EPREFIX}/usr
- [provide_packages]
- pytz = False
- dateutil = False
- [gui_support]
- $(use_setup cairo)
- $(use_setup qt4)
- $(use_setup tk)
- EOF
-
- if [[ ${EPYTHON} == python3* ]]; then
- cat >> "${BUILD_DIR}"/setup.cfg <<-EOF
- six = True
- fltk = False
- fltkagg = False
- gtk = False
- gtkagg = False
- wx = False
- wxagg = False
- EOF
- else
- cat >> "${BUILD_DIR}"/setup.cfg <<-EOF
- six = False
- $(use_setup fltk)
- $(use_setup gtk)
- $(use_setup wxwidgets wx)
- EOF
- fi
-}
-
-wrap_setup() {
- local MPLSETUPCFG=${BUILD_DIR}/setup.cfg
- export MPLSETUPCFG
-
- # Note: remove build... if switching to out-of-source build
- "${@}" build --build-lib="${BUILD_DIR}"/build/lib
-}
-
-python_compile() {
- wrap_setup distutils-r1_python_compile
-}
-
-python_compile_all() {
- if use doc; then
- cd doc || die
-
- # necessary for in-source build
- local -x PYTHONPATH="${BUILD_DIR}"/build/lib:${PYTHONPATH}
-
- unset DISPLAY # bug #278524
- VARTEXFONTS="${T}"/fonts \
- "${PYTHON}" ./make.py --small html || die
- fi
-}
-
-python_test() {
- wrap_setup distutils_install_for_testing
-
- cd "${TMPDIR}" || die
- "${PYTHON}" -c "
-import sys, matplotlib as m
-sys.exit(0 if m.test(verbosity=2) else 1)
-" || die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- wrap_setup distutils-r1_python_install
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
-
- distutils-r1_python_install_all
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/matplotlib/matplotlib-1.4.0.ebuild b/dev-python/matplotlib/matplotlib-1.4.0.ebuild
deleted file mode 100644
index 7533f83eeb27..000000000000
--- a/dev-python/matplotlib/matplotlib-1.4.0.ebuild
+++ /dev/null
@@ -1,247 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.4.0.ebuild,v 1.3 2014/11/23 16:36:23 floppym Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-PYTHON_REQ_USE='tk?'
-
-inherit distutils-r1 eutils flag-o-matic virtualx
-
-DESCRIPTION="Pure python plotting library with matlab like syntax"
-HOMEPAGE="http://matplotlib.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-SLOT="0"
-# Main license: matplotlib
-# Some modules: BSD
-# matplotlib/backends/qt4_editor: MIT
-# Fonts: BitstreamVera, OFL-1.1
-LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="cairo doc excel examples fltk gtk gtk3 latex pyside qt4 test tk wxwidgets"
-
-# #456704 -- a lot of py2-only deps
-PY2_USEDEP=$(python_gen_usedep python2_7)
-COMMON_DEPEND="
- >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
- dev-python/python-dateutil:0[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- >=dev-python/six-1.3[${PYTHON_USEDEP}]
- media-fonts/stix-fonts
- media-libs/freetype:2
- media-libs/libpng:0
- media-libs/qhull
- gtk? (
- dev-libs/glib
- x11-libs/gdk-pixbuf
- x11-libs/gtk+:2
- dev-python/pygtk[${PY2_USEDEP}] )
- wxwidgets? ( >=dev-python/wxpython-2.8[${PY2_USEDEP}] )"
-
-# internal copy of pycxx highly patched
-# dev-python/pycxx
-
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- doc? (
- app-text/dvipng
- virtual/python-imaging[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/numpydoc[${PYTHON_USEDEP}]
- dev-python/xlwt[${PY2_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-fontsrecommended
- dev-texlive/texlive-latexrecommended
- media-gfx/graphviz[cairo]
- )
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/nose-0.11.1[${PYTHON_USEDEP}]
- )"
-
-RDEPEND="${COMMON_DEPEND}
- >=dev-python/pyparsing-1.5.6[${PYTHON_USEDEP}]
- cairo? (
- || (
- dev-python/pycairo[${PYTHON_USEDEP}]
- dev-python/cairocffi[${PYTHON_USEDEP}]
- )
- )
- excel? ( dev-python/xlwt[${PY2_USEDEP}] )
- fltk? ( dev-python/pyfltk[${PY2_USEDEP}] )
- gtk3? (
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- x11-libs/gtk+:3[introspection] )
- latex? (
- virtual/latex-base
- app-text/ghostscript-gpl
- app-text/dvipng
- app-text/poppler[utils]
- dev-texlive/texlive-fontsrecommended
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-xetex
- )
- pyside? ( dev-python/pyside[X,${PYTHON_USEDEP}] )
- qt4? ( dev-python/PyQt4[X,${PYTHON_USEDEP}] )"
-
-PY2_FLAGS="|| ( $(python_gen_useflags python2_7) )"
-REQUIRED_USE="
- doc? ( ${PY2_FLAGS} )
- excel? ( ${PY2_FLAGS} )
- fltk? ( ${PY2_FLAGS} )
- gtk? ( ${PY2_FLAGS} )
- wxwidgets? ( ${PY2_FLAGS} )
- test? (
- cairo fltk latex pyside qt4 tk wxwidgets
- || ( gtk gtk3 )
- )"
-
-RESTRICT="mirror"
-
-# A few C++ source files are written to srcdir.
-# Other than that, the ebuild shall be fit for out-of-source build.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-pkg_setup() {
- unset DISPLAY # bug #278524
-}
-
-use_setup() {
- local uword="${2:-${1}}"
- if use ${1}; then
- echo "${uword} = True"
- echo "${uword}agg = True"
- else
- echo "${uword} = False"
- echo "${uword}agg = False"
- fi
-}
-
-python_prepare_all() {
-# Generates test failures, but fedora does it
-# local PATCHES=(
-# "${FILESDIR}"/${P}-unbundle-pycxx.patch
-# "${FILESDIR}"/${P}-unbundle-agg.patch
-# )
-# rm -r agg24 CXX || die
-# rm -r agg24 || die
-
- sed \
- -e 's/matplotlib.pyparsing_py[23]/pyparsing/g' \
- -i lib/matplotlib/{mathtext,fontconfig_pattern}.py \
- || die "sed pyparsing failed"
-
- # suggested by upstream
- sed \
- -e '/tol/s:32:35:g' \
- -i lib/matplotlib/tests/test_mathtext.py || die
-
- export XDG_RUNTIME_DIR="${T}/runtime-dir"
- mkdir "${XDG_RUNTIME_DIR}" || die
- chmod 0700 "${XDG_RUNTIME_DIR}" || die
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- append-flags -fno-strict-aliasing
-}
-
-python_configure() {
- mkdir -p "${BUILD_DIR}" || die
-
- # create setup.cfg (see setup.cfg.template for any changes).
-
- # common switches.
- cat > "${BUILD_DIR}"/setup.cfg <<- EOF
- [directories]
- basedirlist = "${EPREFIX}/usr"
- [provide_packages]
- pytz = False
- dateutil = False
- [gui_support]
- agg = True
- $(use_setup cairo)
- $(use_setup pyside)
- $(use_setup qt4)
- $(use_setup tk)
- EOF
-
- if use gtk3 && use cairo; then
- echo "gtk3cairo = True" >> "${BUILD_DIR}"/setup.cfg || die
- else
- echo "gtk3cairo = False" >> "${BUILD_DIR}"/setup.cfg || die
- fi
-
- if $(python_is_python3); then
- cat >> "${BUILD_DIR}"/setup.cfg <<- EOF
- six = True
- fltk = False
- fltkagg = False
- gtk = False
- gtkagg = False
- wx = False
- wxagg = False
- EOF
- else
- cat >> "${BUILD_DIR}"/setup.cfg <<-EOF
- six = False
- $(use_setup fltk)
- $(use_setup gtk)
- $(use_setup gtk3)
- $(use_setup wxwidgets wx)
- EOF
- fi
-}
-
-wrap_setup() {
- local MPLSETUPCFG=${BUILD_DIR}/setup.cfg
- export MPLSETUPCFG
-
- # Note: remove build... if switching to out-of-source build
- "${@}" build --build-lib="${BUILD_DIR}"/build/lib
-}
-
-python_compile() {
- wrap_setup distutils-r1_python_compile
-}
-
-python_compile_all() {
- if use doc; then
- cd doc || die
-
- # necessary for in-source build
- local -x PYTHONPATH="${BUILD_DIR}"/build/lib:${PYTHONPATH}
-
- VARTEXFONTS="${T}"/fonts \
- "${PYTHON}" ./make.py --small html || die
- fi
-}
-
-python_test() {
- wrap_setup distutils_install_for_testing
-
- cd "${TMPDIR}" || die
- VIRTUALX_COMMAND="${PYTHON}"
- virtualmake -c "import sys, matplotlib as m; sys.exit(0 if m.test(verbosity=2) else 1)" || \
- die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- wrap_setup distutils-r1_python_install
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
-
- distutils-r1_python_install_all
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/matplotlib/matplotlib-1.4.2.ebuild b/dev-python/matplotlib/matplotlib-1.4.2.ebuild
index f64a1eb29ee0..07f5b4a269e8 100644
--- a/dev-python/matplotlib/matplotlib-1.4.2.ebuild
+++ b/dev-python/matplotlib/matplotlib-1.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.4.2.ebuild,v 1.11 2015/03/09 00:03:04 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.4.2.ebuild,v 1.12 2015/03/20 12:57:09 jlec Exp $
EAPI=5
@@ -35,11 +35,11 @@ COMMON_DEPEND="
media-libs/libpng:0
media-libs/qhull
gtk? (
- dev-libs/glib
+ dev-libs/glib:2=
x11-libs/gdk-pixbuf
- x11-libs/gtk+:2
+ x11-libs/gtk+:2=
dev-python/pygtk[${PY2_USEDEP}] )
- wxwidgets? ( >=dev-python/wxpython-2.8[${PY2_USEDEP}] )"
+ wxwidgets? ( >=dev-python/wxpython-2.8:*[${PY2_USEDEP}] )"
# internal copy of pycxx highly patched
# dev-python/pycxx
diff --git a/dev-python/matplotlib/matplotlib-1.4.3.ebuild b/dev-python/matplotlib/matplotlib-1.4.3.ebuild
index a81f3a372d60..52f388f05ce3 100644
--- a/dev-python/matplotlib/matplotlib-1.4.3.ebuild
+++ b/dev-python/matplotlib/matplotlib-1.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.4.3.ebuild,v 1.1 2015/02/24 16:19:16 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.4.3.ebuild,v 1.2 2015/03/20 12:57:09 jlec Exp $
EAPI=5
@@ -21,7 +21,7 @@ SLOT="0"
# Fonts: BitstreamVera, OFL-1.1
LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="cairo doc excel examples fltk gtk gtk3 latex pyside qt4 test tk wxwidgets"
+IUSE="cairo doc excel examples fltk gtk gtk3 latex pyside qt4 qt5 test tk wxwidgets"
# #456704 -- a lot of py2-only deps
PY2_USEDEP=$(python_gen_usedep python2_7)
@@ -31,15 +31,15 @@ COMMON_DEPEND="
dev-python/pytz[${PYTHON_USEDEP}]
>=dev-python/six-1.4[${PYTHON_USEDEP}]
media-fonts/stix-fonts
- >=media-libs/freetype-2.3
+ media-libs/freetype:2
media-libs/libpng:0
media-libs/qhull
gtk? (
- dev-libs/glib
+ dev-libs/glib:2=
x11-libs/gdk-pixbuf
x11-libs/gtk+:2
dev-python/pygtk[${PY2_USEDEP}] )
- wxwidgets? ( >=dev-python/wxpython-2.8[${PY2_USEDEP}] )"
+ wxwidgets? ( >=dev-python/wxpython-2.8:*[${PY2_USEDEP}] )"
# internal copy of pycxx highly patched
# dev-python/pycxx
@@ -86,7 +86,9 @@ RDEPEND="${COMMON_DEPEND}
dev-texlive/texlive-xetex
)
pyside? ( dev-python/pyside[X,${PYTHON_USEDEP}] )
- qt4? ( dev-python/PyQt4[X,${PYTHON_USEDEP}] )"
+ qt4? ( dev-python/PyQt4[X,${PYTHON_USEDEP}] )
+ qt5? ( dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}] )
+ "
PY2_FLAGS="|| ( $(python_gen_useflags python2_7) )"
REQUIRED_USE="
@@ -96,7 +98,7 @@ REQUIRED_USE="
gtk? ( ${PY2_FLAGS} )
wxwidgets? ( ${PY2_FLAGS} )
test? (
- cairo fltk latex pyside qt4 tk wxwidgets
+ cairo fltk latex pyside qt5 qt4 tk wxwidgets
|| ( gtk gtk3 )
)"
@@ -140,6 +142,10 @@ python_prepare_all() {
-e '/tol/s:32:35:g' \
-i lib/matplotlib/tests/test_mathtext.py || die
+ sed \
+ -e "s:/usr/:${EPREFIX}/usr/:g" \
+ -i setupext.py || die
+
export XDG_RUNTIME_DIR="${T}/runtime-dir"
mkdir "${XDG_RUNTIME_DIR}" || die
chmod 0700 "${XDG_RUNTIME_DIR}" || die
@@ -169,6 +175,7 @@ python_configure() {
$(use_setup cairo)
$(use_setup pyside)
$(use_setup qt4)
+ $(use_setup qt5)
$(use_setup tk)
EOF
diff --git a/dev-python/matplotlib/matplotlib-9999.ebuild b/dev-python/matplotlib/matplotlib-9999.ebuild
index c5de0b3066d6..a6be5622cbbf 100644
--- a/dev-python/matplotlib/matplotlib-9999.ebuild
+++ b/dev-python/matplotlib/matplotlib-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-9999.ebuild,v 1.7 2015/02/24 16:19:16 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-9999.ebuild,v 1.8 2015/03/20 12:57:09 jlec Exp $
EAPI=5
@@ -8,8 +8,6 @@ PYTHON_COMPAT=( python{2_7,3_3,3_4} )
PYTHON_REQ_USE='tk?'
-VIRTUALX_REQUIRED="always"
-
inherit distutils-r1 eutils flag-o-matic git-r3 virtualx
DESCRIPTION="Pure python plotting library with matlab like syntax"
@@ -24,20 +22,25 @@ SLOT="0"
# Fonts: BitstreamVera, OFL-1.1
LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
KEYWORDS=""
-IUSE="cairo doc excel examples fltk gtk gtk3 latex pyside qt4 test tk wxwidgets"
+IUSE="cairo doc excel examples fltk gtk gtk3 latex pyside qt4 qt5 test tk wxwidgets"
# #456704 -- a lot of py2-only deps
-PY2_USEDEP=$(python_gen_usedep 'python2*')
+PY2_USEDEP=$(python_gen_usedep python2_7)
COMMON_DEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
dev-python/python-dateutil:0[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4[${PYTHON_USEDEP}]
media-fonts/stix-fonts
media-libs/freetype:2
media-libs/libpng:0
- gtk? ( dev-python/pygtk[${PY2_USEDEP}] )
- wxwidgets? ( >=dev-python/wxpython-2.8[${PY2_USEDEP}] )"
+ media-libs/qhull
+ gtk? (
+ dev-libs/glib:2=
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ dev-python/pygtk[${PY2_USEDEP}] )
+ wxwidgets? ( >=dev-python/wxpython-2.8:*[${PY2_USEDEP}] )"
# internal copy of pycxx highly patched
# dev-python/pycxx
@@ -48,7 +51,7 @@ DEPEND="${COMMON_DEPEND}
app-text/dvipng
virtual/python-imaging[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/numpydoc[${PY2_USEDEP}]
+ dev-python/numpydoc[${PYTHON_USEDEP}]
dev-python/xlwt[${PY2_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
dev-texlive/texlive-latexextra
@@ -56,7 +59,10 @@ DEPEND="${COMMON_DEPEND}
dev-texlive/texlive-latexrecommended
media-gfx/graphviz[cairo]
)
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/nose-0.11.1[${PYTHON_USEDEP}]
+ )"
RDEPEND="${COMMON_DEPEND}
dev-python/pyparsing[${PYTHON_USEDEP}]
@@ -76,9 +82,11 @@ RDEPEND="${COMMON_DEPEND}
dev-texlive/texlive-xetex
)
pyside? ( dev-python/pyside[X,${PYTHON_USEDEP}] )
- qt4? ( dev-python/PyQt4[X,${PYTHON_USEDEP}] )"
+ qt4? ( dev-python/PyQt4[X,${PYTHON_USEDEP}] )
+ qt5? ( dev-python/PyQt5[X,${PYTHON_USEDEP}] )
+ "
-PY2_FLAGS="|| ( $(python_gen_useflags python2*) )"
+PY2_FLAGS="|| ( $(python_gen_useflags python2_7) )"
REQUIRED_USE="
doc? ( ${PY2_FLAGS} )
excel? ( ${PY2_FLAGS} )
@@ -96,6 +104,10 @@ RESTRICT="mirror"
# Other than that, the ebuild shall be fit for out-of-source build.
DISTUTILS_IN_SOURCE_BUILD=1
+pkg_setup() {
+ unset DISPLAY # bug #278524
+}
+
use_setup() {
local uword="${2:-${1}}"
if use ${1}; then
@@ -115,6 +127,7 @@ python_prepare_all() {
# )
# rm -r agg24 CXX || die
# rm -r agg24 || die
+
sed \
-e 's/matplotlib.pyparsing_py[23]/pyparsing/g' \
-i lib/matplotlib/{mathtext,fontconfig_pattern}.py \
@@ -125,11 +138,14 @@ python_prepare_all() {
-e '/tol/s:32:35:g' \
-i lib/matplotlib/tests/test_mathtext.py || die
- if use gtk || use gtk3; then
- export XDG_RUNTIME_DIR="${T}/runtime-dir"
- mkdir "${XDG_RUNTIME_DIR}" || die
- chmod 0700 "${XDG_RUNTIME_DIR}" || die
- fi
+ sed \
+ -e "s:/usr/:${EPREFIX}/usr/:g" \
+ -i setupext.py || die
+
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
distutils-r1_python_prepare_all
}
@@ -144,9 +160,9 @@ python_configure() {
# create setup.cfg (see setup.cfg.template for any changes).
# common switches.
- cat > "${BUILD_DIR}"/setup.cfg <<-EOF
+ cat > "${BUILD_DIR}"/setup.cfg <<- EOF
[directories]
- basedirlist = ${EPREFIX}/usr
+ basedirlist = "${EPREFIX}/usr"
[provide_packages]
pytz = False
dateutil = False
@@ -155,6 +171,7 @@ python_configure() {
$(use_setup cairo)
$(use_setup pyside)
$(use_setup qt4)
+ $(use_setup qt5)
$(use_setup tk)
EOF
@@ -165,7 +182,7 @@ python_configure() {
fi
if $(python_is_python3); then
- cat >> "${BUILD_DIR}"/setup.cfg <<-EOF
+ cat >> "${BUILD_DIR}"/setup.cfg <<- EOF
six = True
fltk = False
fltkagg = False
@@ -194,8 +211,7 @@ wrap_setup() {
}
python_compile() {
- VIRTUALX_COMMAND="wrap_setup distutils-r1_python_compile"
- virtualmake
+ wrap_setup distutils-r1_python_compile
}
python_compile_all() {
@@ -205,7 +221,6 @@ python_compile_all() {
# necessary for in-source build
local -x PYTHONPATH="${BUILD_DIR}"/build/lib:${PYTHONPATH}
- unset DISPLAY # bug #278524
VARTEXFONTS="${T}"/fonts \
"${PYTHON}" ./make.py --small html || die
fi