summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-01-08 03:48:51 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-01-08 03:48:51 +0000
commit58601355ee35193c06ef201492c110bb9e61e948 (patch)
tree2b04c70e9014a82194d1a639c63621fa28f18b68 /dev-python/logilab-common
parentVersion bump. (diff)
downloadgentoo-2-58601355ee35193c06ef201492c110bb9e61e948.tar.gz
gentoo-2-58601355ee35193c06ef201492c110bb9e61e948.tar.bz2
gentoo-2-58601355ee35193c06ef201492c110bb9e61e948.zip
Bump
(Portage version: 2.2.8/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/logilab-common')
-rw-r--r--dev-python/logilab-common/ChangeLog9
-rw-r--r--dev-python/logilab-common/logilab-common-0.60.1.ebuild76
2 files changed, 83 insertions, 2 deletions
diff --git a/dev-python/logilab-common/ChangeLog b/dev-python/logilab-common/ChangeLog
index a2483c2fd3a5..08bde57a54ed 100644
--- a/dev-python/logilab-common/ChangeLog
+++ b/dev-python/logilab-common/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/logilab-common
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/ChangeLog,v 1.132 2013/12/02 12:21:44 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/ChangeLog,v 1.133 2014/01/08 03:48:51 patrick Exp $
+
+*logilab-common-0.60.1 (08 Jan 2014)
+
+ 08 Jan 2014; Patrick Lauer <patrick@gentoo.org> +logilab-common-0.60.1.ebuild:
+ Bump
02 Dec 2013; Michał Górny <mgorny@gentoo.org> logilab-common-0.59.1.ebuild,
logilab-common-0.60.0.ebuild:
diff --git a/dev-python/logilab-common/logilab-common-0.60.1.ebuild b/dev-python/logilab-common/logilab-common-0.60.1.ebuild
new file mode 100644
index 000000000000..d013b1e42fd8
--- /dev/null
+++ b/dev-python/logilab-common/logilab-common-0.60.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/logilab-common-0.60.1.ebuild,v 1.1 2014/01/08 03:48:51 patrick Exp $
+
+EAPI=5
+
+# 0.60.0 fails unittest_umessage with python3.3
+# http://www.logilab.org/ticket/149345
+PYTHON_COMPAT=( python{2_6,2_7,3_2} pypy2_0 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Useful miscellaneous modules used by Logilab projects"
+HOMEPAGE="http://www.logilab.org/project/logilab-common http://pypi.python.org/pypi/logilab-common"
+SRC_URI="ftp://ftp.logilab.org/pub/common/${P}.tar.gz mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test doc"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/python-unittest2[${PYTHON_USEDEP}]"
+
+# Tests using dev-python/psycopg are skipped when dev-python/psycopg
+# isn't installed.
+# egenix-mx-base tests are optional, and egenix-mx-base does support
+# Python2 only.
+DEPEND="${RDEPEND}
+ test? (
+ $(python_gen_cond_dep dev-python/egenix-mx-base[$(python_gen_usedep 'python2*')] 'python2*')
+ !dev-python/psycopg[-mxdatetime]
+ )
+ doc? ( dev-python/epydoc )"
+
+PATCHES=(
+ # Make sure setuptools does not create a zip file in python_test;
+ # this is buggy and causes tests to fail.
+ "${FILESDIR}/${PN}-0.59.1-zipsafe.patch"
+
+ # Depends on order of dictionary keys
+ "${FILESDIR}/logilab-common-0.60.0-skip-doctest.patch"
+)
+
+python_prepare_all() {
+ sed -e 's:(CURDIR):{S}/${P}:' -i doc/makefile || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ # Simplest way to make makefile point to the right place.
+ ln -s "${BUILD_DIR}" build || die
+ emake -C doc epydoc
+ rm build || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+
+ # Prevent timezone related failure.
+ export TZ=UTC
+
+ # Make sure that the tests use correct modules.
+ pushd "${TEST_DIR}"/lib > /dev/null || die
+ "${TEST_DIR}"/scripts/pytest || die "Tests fail with ${EPYTHON}"
+ popd > /dev/null || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doman doc/pytest.1
+ use doc && dohtml -r doc/apidoc/.
+}