summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-31 08:11:29 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-31 08:11:29 +0000
commit26432e8adc3654aa44128704121ba79862dca646 (patch)
tree0ee2565fafc784fde1333b2951cf90ed6cd31c04 /dev-python/logbook
parentVersion bump (diff)
downloadgentoo-2-26432e8adc3654aa44128704121ba79862dca646.tar.gz
gentoo-2-26432e8adc3654aa44128704121ba79862dca646.tar.bz2
gentoo-2-26432e8adc3654aa44128704121ba79862dca646.zip
bump; drop py2.6 pypy2_0 add py3.4 support, update test phase failings
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/logbook')
-rw-r--r--dev-python/logbook/ChangeLog7
-rw-r--r--dev-python/logbook/logbook-0.7.0.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-python/logbook/ChangeLog b/dev-python/logbook/ChangeLog
index 4f1c69bb29a0..90300ffcf020 100644
--- a/dev-python/logbook/ChangeLog
+++ b/dev-python/logbook/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/logbook
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/ChangeLog,v 1.16 2014/04/12 00:16:50 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/ChangeLog,v 1.17 2014/05/31 08:11:29 idella4 Exp $
+
+*logbook-0.7.0 (31 May 2014)
+
+ 31 May 2014; Ian Delaney <idella4@gentoo.org> +logbook-0.7.0.ebuild:
+ bump; drop py2.6 pypy2_0 add py3.4 support, update test phase failings
*logbook-0.6.0 (12 Apr 2014)
diff --git a/dev-python/logbook/logbook-0.7.0.ebuild b/dev-python/logbook/logbook-0.7.0.ebuild
new file mode 100644
index 000000000000..54f709b5f310
--- /dev/null
+++ b/dev-python/logbook/logbook-0.7.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/logbook-0.7.0.ebuild,v 1.1 2014/05/31 08:11:29 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A logging replacement for Python"
+HOMEPAGE="http://packages.python.org/Logbook/ http://pypi.python.org/pypi/Logbook"
+SRC_URI="https://github.com/mitsuhiko/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ doc? ( >=dev-python/sphinx-1.1.3-r3[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.4.2-objectsinv.patch )
+
+python_prepare_all() {
+ # https://github.com/mitsuhiko/logbook/issues/109
+ sed -e s':test_redis_handle:_&:' -i tests/test_logbook.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests -w tests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}