summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-19 22:38:04 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-19 22:38:04 +0000
commit5f7aaf7d7bbdf339c279c1202a334d9b69fdf2bb (patch)
tree50d0f803c32cdf1f3617fecebdb64194b26e56d0 /dev-python/lockfile
parentwhitespace (diff)
downloadgentoo-2-5f7aaf7d7bbdf339c279c1202a334d9b69fdf2bb.tar.gz
gentoo-2-5f7aaf7d7bbdf339c279c1202a334d9b69fdf2bb.tar.bz2
gentoo-2-5f7aaf7d7bbdf339c279c1202a334d9b69fdf2bb.zip
Version bump.
(Portage version: 2.2_rc84_p3/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/lockfile')
-rw-r--r--dev-python/lockfile/ChangeLog8
-rw-r--r--dev-python/lockfile/lockfile-0.9.1.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/lockfile/ChangeLog b/dev-python/lockfile/ChangeLog
index eb0ce4c85f28..54456afa1777 100644
--- a/dev-python/lockfile/ChangeLog
+++ b/dev-python/lockfile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/lockfile
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lockfile/ChangeLog,v 1.5 2010/06/28 08:45:42 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lockfile/ChangeLog,v 1.6 2010/09/19 22:38:04 arfrever Exp $
+
+*lockfile-0.9.1 (19 Sep 2010)
+
+ 19 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +lockfile-0.9.1.ebuild:
+ Version bump.
28 Jun 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> lockfile-0.9.ebuild:
x86 stable wrt bug #323693
diff --git a/dev-python/lockfile/lockfile-0.9.1.ebuild b/dev-python/lockfile/lockfile-0.9.1.ebuild
new file mode 100644
index 000000000000..79827df624bd
--- /dev/null
+++ b/dev-python/lockfile/lockfile-0.9.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lockfile/lockfile-0.9.1.ebuild,v 1.1 2010/09/19 22:38:04 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit distutils
+
+DESCRIPTION="Platform-independent file locking module"
+HOMEPAGE="http://code.google.com/p/pylockfile/ http://pypi.python.org/pypi/lockfile http://smontanaro.dyndns.org/python/"
+SRC_URI="http://pylockfile.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( dev-python/sphinx )"
+RDEPEND=""
+
+DOCS="ACKS README RELEASE-NOTES"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ cd doc
+ emake html || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ cd doc/.build/html
+ docinto html
+ cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html" || die "Installation of documentation failed"
+ fi
+}