summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-07-21 08:27:22 +0000
committerTim Harder <radhermit@gentoo.org>2013-07-21 08:27:22 +0000
commit606911889c1f71be20f1cc9038adc75144ff4839 (patch)
tree1703e643203f1a1a2038592b99b705d8d5845606 /dev-python/llfuse
parentCleanup due #88306 (diff)
downloadgentoo-2-606911889c1f71be20f1cc9038adc75144ff4839.tar.gz
gentoo-2-606911889c1f71be20f1cc9038adc75144ff4839.tar.bz2
gentoo-2-606911889c1f71be20f1cc9038adc75144ff4839.zip
Use system setuptools (bug #436346).
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/llfuse')
-rw-r--r--dev-python/llfuse/ChangeLog5
-rw-r--r--dev-python/llfuse/llfuse-0.39.ebuild7
2 files changed, 10 insertions, 2 deletions
diff --git a/dev-python/llfuse/ChangeLog b/dev-python/llfuse/ChangeLog
index f8d66bde727f..7eede566b4e0 100644
--- a/dev-python/llfuse/ChangeLog
+++ b/dev-python/llfuse/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/llfuse
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/llfuse/ChangeLog,v 1.11 2013/07/08 10:37:47 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/llfuse/ChangeLog,v 1.12 2013/07/21 08:27:22 radhermit Exp $
+
+ 21 Jul 2013; Tim Harder <radhermit@gentoo.org> llfuse-0.39.ebuild:
+ Use system setuptools (bug #436346).
08 Jul 2013; Ian Delaney <idella4@gentoo.org> llfuse-0.39.ebuild:
Add pypy support, IUSE examples
diff --git a/dev-python/llfuse/llfuse-0.39.ebuild b/dev-python/llfuse/llfuse-0.39.ebuild
index 3573e85a9f80..153831735d85 100644
--- a/dev-python/llfuse/llfuse-0.39.ebuild
+++ b/dev-python/llfuse/llfuse-0.39.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/llfuse/llfuse-0.39.ebuild,v 1.2 2013/07/08 10:37:47 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/llfuse/llfuse-0.39.ebuild,v 1.3 2013/07/21 08:27:22 radhermit Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} pypy2_0 )
@@ -21,6 +21,11 @@ DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
virtual/pkgconfig"
+python_prepare_all() {
+ # use system setuptools
+ sed -i '/use_setuptools/d' setup.py || die
+}
+
python_install_all() {
use doc && local HTML_DOCS=( doc/html/. )
use examples && local EXAMPLES=( examples/. )