summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2005-11-10 23:32:10 +0000
committerRob Cakebread <pythonhead@gentoo.org>2005-11-10 23:32:10 +0000
commit039ff3ed557a8179af3f90fe3403552abd4084dd (patch)
tree967f2fd94373618400be666a7308fcce2c200b09 /dev-python/kid
parentVersion bump. Removing older ebuilds. (diff)
downloadgentoo-2-039ff3ed557a8179af3f90fe3403552abd4084dd.tar.gz
gentoo-2-039ff3ed557a8179af3f90fe3403552abd4084dd.tar.bz2
gentoo-2-039ff3ed557a8179af3f90fe3403552abd4084dd.zip
Initial commit.
(Portage version: 1.589-cvs)
Diffstat (limited to 'dev-python/kid')
-rw-r--r--dev-python/kid/ChangeLog10
-rw-r--r--dev-python/kid/Manifest15
-rw-r--r--dev-python/kid/files/digest-kid-0.7.11
-rw-r--r--dev-python/kid/files/kid-0.7.1-ezsetup-gentoo.patch27
-rw-r--r--dev-python/kid/kid-0.7.1.ebuild30
-rw-r--r--dev-python/kid/metadata.xml5
6 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/kid/ChangeLog b/dev-python/kid/ChangeLog
new file mode 100644
index 000000000000..d49a69fde457
--- /dev/null
+++ b/dev-python/kid/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/kid
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kid/ChangeLog,v 1.1 2005/11/10 23:32:10 pythonhead Exp $
+
+*kid-0.7.1 (10 Nov 2005)
+
+ 10 Nov 2005; Rob Cakebread <pythonhead@gentoo.org>
+ +files/kid-0.7.1-ezsetup-gentoo.patch, +metadata.xml, +kid-0.7.1.ebuild:
+ Initial commit.
+
diff --git a/dev-python/kid/Manifest b/dev-python/kid/Manifest
new file mode 100644
index 000000000000..40cd5eee72d6
--- /dev/null
+++ b/dev-python/kid/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 2c7afe365463720efe48dd39805f112a kid-0.7.1.ebuild 645
+MD5 9ac4199ebe7cd3e7e311274994767f82 metadata.xml 160
+MD5 95931356a9ebda66dc38f5c32754e6c4 ChangeLog 288
+MD5 6afe8df6927655a755c858926a52bc5e files/kid-0.7.1-ezsetup-gentoo.patch 785
+MD5 fe1c90896206e3460519d78d6c59862b files/digest-kid-0.7.1 61
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFDc9hoTry2jroju7wRArL4AJ97nqXuMt98i0kNF9a7wf7KS6mcawCfb/rv
+Bk5X98HFZW+zJkUsLxcmy6M=
+=VZGX
+-----END PGP SIGNATURE-----
diff --git a/dev-python/kid/files/digest-kid-0.7.1 b/dev-python/kid/files/digest-kid-0.7.1
new file mode 100644
index 000000000000..00281aca727d
--- /dev/null
+++ b/dev-python/kid/files/digest-kid-0.7.1
@@ -0,0 +1 @@
+MD5 9e8bdad66c964655a7ab0b84969444f3 kid-0.7.1.tar.gz 165733
diff --git a/dev-python/kid/files/kid-0.7.1-ezsetup-gentoo.patch b/dev-python/kid/files/kid-0.7.1-ezsetup-gentoo.patch
new file mode 100644
index 000000000000..6f0b2b4fc0a4
--- /dev/null
+++ b/dev-python/kid/files/kid-0.7.1-ezsetup-gentoo.patch
@@ -0,0 +1,27 @@
+--- setup.py.org 2005-11-10 15:10:23.839116952 -0800
++++ setup.py 2005-11-10 15:10:48.734332304 -0800
+@@ -1,6 +1,4 @@
+ # bootstrap setuptools if necessary
+-from ez_setup import use_setuptools
+-use_setuptools()
+
+ import kid as package
+
+@@ -8,7 +6,7 @@
+ package_version = package.__version__
+ doc_parts = package.__doc__.strip().splitlines()
+
+-from setuptools import setup
++from distutils.core import setup
+ setup(
+ name=package_name,
+ version=package_version,
+@@ -25,8 +23,6 @@
+ py_modules=[],
+ packages=[package_name,
+ package_name + '.test'],
+- install_requires=['elementtree'],
+- extras_require = { 'cElementTree' : ["cElementTree"] },
+ classifiers = [
+ 'Development Status :: 3 - Alpha',
+ 'Environment :: Console',
diff --git a/dev-python/kid/kid-0.7.1.ebuild b/dev-python/kid/kid-0.7.1.ebuild
new file mode 100644
index 000000000000..74529ff84e79
--- /dev/null
+++ b/dev-python/kid/kid-0.7.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kid/kid-0.7.1.ebuild,v 1.1 2005/11/10 23:32:10 pythonhead Exp $
+
+inherit distutils
+
+DESCRIPTION="A simple and Pythonic XML template language"
+SRC_URI="http://kid.lesscode.org/dist/${PV}/${P}.tar.gz"
+HOMEPAGE="http://kid.lesscode.org/"
+
+KEYWORDS="~x86"
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3
+ >=dev-python/elementtree-1.2.6"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} || die "Failed to unpack ${A}"
+ #Use distutils instead of egg
+ epatch ${FILESDIR}/${P}-ezsetup-gentoo.patch
+}
+
+pkg_postinst() {
+ einfo "Installing dev-python/celementree may enhance performance."
+}
+
diff --git a/dev-python/kid/metadata.xml b/dev-python/kid/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/dev-python/kid/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>