summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-10-04 10:33:23 +0000
committerIan Delaney <idella4@gentoo.org>2014-10-04 10:33:23 +0000
commit734949ea5d80257c97cde7d98531a49e862e907a (patch)
tree7056ae09e48375e51228b8258497758775bdb51d /dev-python/jsonpickle
parentNeeds python liblouis (diff)
downloadgentoo-2-734949ea5d80257c97cde7d98531a49e862e907a.tar.gz
gentoo-2-734949ea5d80257c97cde7d98531a49e862e907a.tar.bz2
gentoo-2-734949ea5d80257c97cde7d98531a49e862e907a.zip
bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/jsonpickle')
-rw-r--r--dev-python/jsonpickle/ChangeLog7
-rw-r--r--dev-python/jsonpickle/jsonpickle-0.8.0.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-python/jsonpickle/ChangeLog b/dev-python/jsonpickle/ChangeLog
index 9a25b39ab588..f5885f7a515d 100644
--- a/dev-python/jsonpickle/ChangeLog
+++ b/dev-python/jsonpickle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/jsonpickle
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpickle/ChangeLog,v 1.23 2014/09/24 19:40:49 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpickle/ChangeLog,v 1.24 2014/10/04 10:33:23 idella4 Exp $
+
+*jsonpickle-0.8.0 (04 Oct 2014)
+
+ 04 Oct 2014; Ian Delaney <idella4@gentoo.org> +jsonpickle-0.8.0.ebuild:
+ bump
24 Sep 2014; Markus Meier <maekke@gentoo.org> jsonpickle-0.7.2.ebuild:
add ~arm, bug #519616
diff --git a/dev-python/jsonpickle/jsonpickle-0.8.0.ebuild b/dev-python/jsonpickle/jsonpickle-0.8.0.ebuild
new file mode 100644
index 000000000000..825b985a6f05
--- /dev/null
+++ b/dev-python/jsonpickle/jsonpickle-0.8.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpickle/jsonpickle-0.8.0.ebuild,v 1.1 2014/10/04 10:33:23 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for serializing any arbitrary object graph into JSON"
+HOMEPAGE="http://jsonpickle.github.com/ http://pypi.python.org/pypi/jsonpickle"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+# There are optional json backends in addition to those selected here
+# jsonlib, demjson, yajl, jsonlib
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND} )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/sphinxtogithub[${PYTHON_USEDEP}]' python2_7) )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.6.1-drop-brocken-backend.patch )
+
+python_prepare_all() {
+ # Prevent un-needed d'loading during doc build
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/source/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && sphinx-build -b html -c docs/source/ docs/source/ docs/source/html
+}
+
+python_test() {
+ einfo "testsuite has optional tests for package demjson"
+ ${PYTHON} tests/runtests.py || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/source/html/. )
+ distutils-r1_python_install_all
+}