summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-24 11:56:41 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-24 11:56:41 +0000
commitef782c4da60396e8ebd6696e2dcafbc132e7f1fb (patch)
treefe190c89d0f94d2cecd6cd0d0dc2686857e6968f /dev-python/ipy
parentStable for ppc, wrt bug #473432 (diff)
downloadgentoo-2-ef782c4da60396e8ebd6696e2dcafbc132e7f1fb.tar.gz
gentoo-2-ef782c4da60396e8ebd6696e2dcafbc132e7f1fb.tar.bz2
gentoo-2-ef782c4da60396e8ebd6696e2dcafbc132e7f1fb.zip
bump
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/ipy')
-rw-r--r--dev-python/ipy/ChangeLog7
-rw-r--r--dev-python/ipy/ipy-0.81.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/ipy/ChangeLog b/dev-python/ipy/ChangeLog
index f4f3e4dd77df..dd5239b2adf2 100644
--- a/dev-python/ipy/ChangeLog
+++ b/dev-python/ipy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/ipy
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipy/ChangeLog,v 1.39 2013/04/06 15:33:37 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipy/ChangeLog,v 1.40 2013/06/24 11:56:41 idella4 Exp $
+
+*ipy-0.81 (24 Jun 2013)
+
+ 24 Jun 2013; Ian Delaney <idella4@gentoo.org> +ipy-0.81.ebuild:
+ bump
06 Apr 2013; Mike Gilbert <floppym@gentoo.org> ipy-0.76-r1.ebuild:
Use pushd/popd in python_test.
diff --git a/dev-python/ipy/ipy-0.81.ebuild b/dev-python/ipy/ipy-0.81.ebuild
new file mode 100644
index 000000000000..09d7ffbe8b37
--- /dev/null
+++ b/dev-python/ipy/ipy-0.81.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipy/ipy-0.81.ebuild,v 1.1 2013/06/24 11:56:41 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+MY_PN="IPy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Class and tools for handling of IPv4 and IPv6 addresses and networks"
+HOMEPAGE="https://github.com/haypo/python-ipy/wiki http://pypi.python.org/pypi/IPy"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( ChangeLog README )
+
+python_test() {
+ # doctests for py3 unaltered read py2 files from "${S}" causing total failure
+ # https://github.com/haypo/python-ipy/issues/17
+ cp -r test_doc.py README test "${BUILD_DIR}" || die
+ pushd "${BUILD_DIR}" > /dev/null || die
+ "${PYTHON}" test/test_IPy.py || die "Tests fail with ${EPYTHON}"
+ "${PYTHON}" test_doc.py || die "Doctests fail with ${EPYTHON}"
+ popd > /dev/null || die
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}