summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-01 23:04:44 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-01 23:04:44 +0000
commit11690ec70032a6eae3736fa0f7bdd0baf7925652 (patch)
tree774609adb2ad777470a5b238786fafd6eaf10538 /dev-python/imaging
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-11690ec70032a6eae3736fa0f7bdd0baf7925652.tar.gz
gentoo-2-11690ec70032a6eae3736fa0f7bdd0baf7925652.tar.bz2
gentoo-2-11690ec70032a6eae3736fa0f7bdd0baf7925652.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 13874-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/imaging')
-rw-r--r--dev-python/imaging/ChangeLog6
-rw-r--r--dev-python/imaging/imaging-1.1.6-r1.ebuild36
2 files changed, 27 insertions, 15 deletions
diff --git a/dev-python/imaging/ChangeLog b/dev-python/imaging/ChangeLog
index ccc3475d5c97..732b9446e437 100644
--- a/dev-python/imaging/ChangeLog
+++ b/dev-python/imaging/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/imaging
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/ChangeLog,v 1.42 2009/07/15 17:03:32 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/ChangeLog,v 1.43 2009/08/01 23:04:44 arfrever Exp $
+
+ 01 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ imaging-1.1.6-r1.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
15 Jul 2009; Sébastien Fabbro <bicatali@gentoo.org>
files/imaging-1.1.6-tiffendian.patch:
diff --git a/dev-python/imaging/imaging-1.1.6-r1.ebuild b/dev-python/imaging/imaging-1.1.6-r1.ebuild
index 7eaa06836420..2edc68aa14e5 100644
--- a/dev-python/imaging/imaging-1.1.6-r1.ebuild
+++ b/dev-python/imaging/imaging-1.1.6-r1.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/imaging-1.1.6-r1.ebuild,v 1.3 2009/07/03 09:57:58 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/imaging-1.1.6-r1.ebuild,v 1.4 2009/08/01 23:04:44 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
-EAPI=2
inherit eutils distutils
MY_P=Imaging-${PV}
@@ -23,6 +25,8 @@ DEPEND="media-libs/jpeg
X? ( x11-misc/xdg-utils )"
RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3*"
+
PYTHON_MODNAME=PIL
S="${WORKDIR}/${MY_P}"
@@ -36,7 +40,7 @@ src_prepare() {
-e "s:/usr/lib\":/usr/$(get_libdir)\":" \
-e "s:\"lib\":\"$(get_libdir)\":g" \
setup.py || die "sed failed"
- if ! use tk ; then
+ if ! use tk; then
# Make the test always fail
sed -i \
-e 's/import _tkinter/raise ImportError/' \
@@ -46,15 +50,17 @@ src_prepare() {
src_compile() {
distutils_src_compile
- if use scanner ; then
+ if use scanner; then
cd "${S}/Sane"
distutils_src_compile
fi
}
src_test() {
- find . -name _imaging\*.so | xargs -r cp -v -p --target-directory=./PIL/
- "${python}" selftest.py || die
+ tests() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "${python}" selftest.py
+ }
+ python_execute_function tests
}
src_install() {
@@ -63,7 +69,7 @@ src_install() {
use doc && dohtml Docs/*
- if use scanner ; then
+ if use scanner; then
cd "${S}/Sane"
docinto sane
local DOCS="CHANGES sanedoc.txt"
@@ -71,16 +77,18 @@ src_install() {
cd "${S}"
fi
- # install headers required by media-gfx/sketch
- distutils_python_version
- insinto /usr/include/python${PYVER}
- doins libImaging/Imaging.h
- doins libImaging/ImPlatform.h
+ # Install headers required by media-gfx/sketch.
+ install_headers() {
+ insinto "$(python_get_includedir)"
+ doins libImaging/Imaging.h
+ doins libImaging/ImPlatform.h
+ }
+ python_execute_function install_headers
- if use examples ; then
+ if use examples; then
insinto /usr/share/doc/${PF}/examples
doins Scripts/*
- if use scanner ; then
+ if use scanner; then
insinto /usr/share/doc/${PF}/examples/sane
doins Sane/demo_*.py
fi