summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-19 22:17:22 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-19 22:17:22 +0000
commit4f5422bf19822e4738ae1248cc8236381e58a169 (patch)
treed505e57f26874667c5a5295413dd22d6d61c69c0 /dev-python/icalendar
parentVersion bump, also fix BL2 issue per bug #241884. (diff)
downloadgentoo-2-4f5422bf19822e4738ae1248cc8236381e58a169.tar.gz
gentoo-2-4f5422bf19822e4738ae1248cc8236381e58a169.tar.bz2
gentoo-2-4f5422bf19822e4738ae1248cc8236381e58a169.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
(Portage version: 15121-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/icalendar')
-rw-r--r--dev-python/icalendar/ChangeLog8
-rw-r--r--dev-python/icalendar/icalendar-2.1.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/icalendar/ChangeLog b/dev-python/icalendar/ChangeLog
index e54375cbd844..07a35bc708e1 100644
--- a/dev-python/icalendar/ChangeLog
+++ b/dev-python/icalendar/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/icalendar
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/ChangeLog,v 1.2 2009/09/19 11:10:47 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/ChangeLog,v 1.3 2009/12/19 22:17:22 arfrever Exp $
+
+*icalendar-2.1 (19 Dec 2009)
+
+ 19 Dec 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +icalendar-2.1.ebuild:
+ Version bump. Set SUPPORT_PYTHON_ABIS.
19 Sep 2009; Markus Meier <maekke@gentoo.org> icalendar-2.0.1.ebuild:
amd64/x86 stable, bug #285035
diff --git a/dev-python/icalendar/icalendar-2.1.ebuild b/dev-python/icalendar/icalendar-2.1.ebuild
new file mode 100644
index 000000000000..7a33d0411172
--- /dev/null
+++ b/dev-python/icalendar/icalendar-2.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/icalendar-2.1.ebuild,v 1.1 2009/12/19 22:17:22 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)."
+HOMEPAGE="http://codespeak.net/icalendar/ http://pypi.python.org/pypi/icalendar"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+DOCS="CHANGES.txt CREDITS.txt doc/* HISTORY.txt README.txt TODO.txt"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.0.1-UIDGenerator-fix.patch"
+}
+
+src_test() {
+ testing() {
+ "$(PYTHON)" test.py
+ }
+ python_execute_function testing
+}