summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-11-26 06:38:58 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-11-26 06:38:58 +0000
commit7a73cf68d1929527e95cd3bfbd964704d98c950c (patch)
tree17ebbe76522fc6fb121d80c6c309e4c50d52eacd /dev-python/hcs-utils
parentBump (diff)
downloadgentoo-2-7a73cf68d1929527e95cd3bfbd964704d98c950c.tar.gz
gentoo-2-7a73cf68d1929527e95cd3bfbd964704d98c950c.tar.bz2
gentoo-2-7a73cf68d1929527e95cd3bfbd964704d98c950c.zip
Bump
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/hcs-utils')
-rw-r--r--dev-python/hcs-utils/ChangeLog7
-rw-r--r--dev-python/hcs-utils/hcs-utils-1.4.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/hcs-utils/ChangeLog b/dev-python/hcs-utils/ChangeLog
index 5392ab38040d..e7e3fc8bc012 100644
--- a/dev-python/hcs-utils/ChangeLog
+++ b/dev-python/hcs-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/hcs-utils
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/hcs-utils/ChangeLog,v 1.7 2013/06/23 04:51:55 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hcs-utils/ChangeLog,v 1.8 2013/11/26 06:38:58 patrick Exp $
+
+*hcs-utils-1.4 (26 Nov 2013)
+
+ 26 Nov 2013; Patrick Lauer <patrick@gentoo.org> +hcs-utils-1.4.ebuild:
+ Bump
*hcs-utils-1.4_rc5 (23 Jun 2013)
diff --git a/dev-python/hcs-utils/hcs-utils-1.4.ebuild b/dev-python/hcs-utils/hcs-utils-1.4.ebuild
new file mode 100644
index 000000000000..866fc7cde58f
--- /dev/null
+++ b/dev-python/hcs-utils/hcs-utils-1.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hcs-utils/hcs-utils-1.4.ebuild,v 1.1 2013/11/26 06:38:58 patrick Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+MY_P=${P/_rc/rc}
+DESCRIPTION="A library containing some useful snippets"
+HOMEPAGE="http://pypi.python.org/pypi/hcs_utils"
+SRC_URI="mirror://pypi/h/${PN/-/_}/${MY_P/-/_}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P/-/_}"
+
+python_test() {
+ cd "${BUILD_DIR}/lib" || die
+ py.test --doctest-modules hcs_utils || die
+}