summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-01-06 12:37:56 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-01-06 12:37:56 +0000
commitc2aec2b203d85df7082aca483ab06be5c3021683 (patch)
treebd81dd81c61f611bddbdedd719978056b86b021e /dev-python/gst-python
parentdev-java/tomcat-servlet-api: removed old version (diff)
downloadgentoo-2-c2aec2b203d85df7082aca483ab06be5c3021683.tar.gz
gentoo-2-c2aec2b203d85df7082aca483ab06be5c3021683.tar.bz2
gentoo-2-c2aec2b203d85df7082aca483ab06be5c3021683.zip
Empty py-compile script instead of symlinking it to /path/to/true for automake-1.11.2 compability wrt #396689 by Juergen Rose
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/gst-python')
-rw-r--r--dev-python/gst-python/ChangeLog9
-rw-r--r--dev-python/gst-python/gst-python-0.10.22.ebuild21
2 files changed, 18 insertions, 12 deletions
diff --git a/dev-python/gst-python/ChangeLog b/dev-python/gst-python/ChangeLog
index 37195b904246..fe309385820c 100644
--- a/dev-python/gst-python/ChangeLog
+++ b/dev-python/gst-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/gst-python
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/ChangeLog,v 1.103 2011/10/29 18:26:51 leio Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/ChangeLog,v 1.104 2012/01/06 12:37:56 ssuominen Exp $
+
+ 06 Jan 2012; Samuli Suominen <ssuominen@gentoo.org>
+ gst-python-0.10.22.ebuild:
+ Empty py-compile script instead of symlinking it to /path/to/true for
+ automake-1.11.2 compability wrt #396689 by Juergen Rose
*gst-python-0.10.22 (29 Oct 2011)
diff --git a/dev-python/gst-python/gst-python-0.10.22.ebuild b/dev-python/gst-python/gst-python-0.10.22.ebuild
index 0803b5f9db85..c802523f3ebe 100644
--- a/dev-python/gst-python/gst-python-0.10.22.ebuild
+++ b/dev-python/gst-python/gst-python-0.10.22.ebuild
@@ -1,16 +1,18 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/gst-python-0.10.22.ebuild,v 1.1 2011/10/29 18:26:51 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/gst-python-0.10.22.ebuild,v 1.2 2012/01/06 12:37:56 ssuominen Exp $
-EAPI=3
-PYTHON_DEPEND="2"
+EAPI=4
+
+PYTHON_DEPEND="2:2.6"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"
PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+
inherit autotools eutils python
DESCRIPTION="A Python Interface to GStreamer"
-HOMEPAGE="http://gstreamer.freedesktop.org"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
LICENSE="LGPL-2"
@@ -18,10 +20,10 @@ SLOT="0.10"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
IUSE="examples test"
-RDEPEND="|| ( >=dev-python/pygobject-2.11.2:2 >=dev-python/pygtk-2.6.3 )
+RDEPEND="dev-libs/libxml2
+ >=dev-python/pygobject-2.28:2
>=media-libs/gstreamer-0.10.32
- >=media-libs/gst-plugins-base-0.10.32
- dev-libs/libxml2"
+ >=media-libs/gst-plugins-base-0.10.32"
DEPEND="${RDEPEND}
dev-util/pkgconfig
test? (
@@ -31,8 +33,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${PN}-0.10.9-lazy.patch
- rm -f py-compile ltmain.sh common/m4/{libtool,lt*}.m4 || die "rm -f failed"
- ln -s $(type -P true) py-compile
+ >py-compile #396689
AT_M4DIR="common/m4" eautoreconf
python_src_prepare
}